child positions not honored on restart/Resize panes on startup

Asked by Anaximander Thales on 2013-11-11

I asked this originally in "How to resize all windows evenly? -- Question #232167," but you have that marked solved, and in terms of proper protocol, decided I just needed to open a new question. I apologize for the impropriety.

I had been looking for a way to evenly resize the panes as well. While it's great that I can double click the splitter, is there a way to make that occur on startup of terminator? I have to power off the computer when I am away (corporate policy, longer than 15 minute idle time invokes a power down -- not sleep, an actual power down), which could mean potentially having to resize four, five or six times a day due to meetings and lunches. Having this just be resized on start would be awesome.

I have played around with setting the proper sizes in the config file, but those sizes are not honored at start up, they revert to the 50:50 split.

I saw that you'd prefer wishlist items added to the bug report so you can move them yourself. Is this already available to have proper sizes on start up? Are you already working on it or should I add that to the bug report?

Question information

English Edit question
Terminator Edit question
No assignee Edit question
Solved by:
Anaximander Thales
Last query:
Last reply:

I'm making an assumption here that you're using layouts to launch a window with multliple terminals, and that they are not remembering the correct positions. In rev 1447 I made a change to store ratios rather than absolute positions for the splitter panes. My comment says it was more reliable. I'm not sure whether this means it was broken beforehand, but I can say that the current trunk always opens with the remembered ratios now because I use trunk as my day-to-day version. You will need to re-save your layout(s), or edit the file and add i.e. ratio = 0.5 to the V/HPanes.
Mind that the ratio is not normally that because this doesn't allow for the splitter width. My config file has values like: ratio = 0.49765625. (Splitter width = 1 - (0.49765625 x 2) )

If you test the current trunk and it is still not working, you will have to raise a bug report. If you cannot run trunk you will need to wait till a new release.

Got the nightly builds ppa loaded up, updated terminator. Added the layout, and loaded terminator with the layout (saw in the config file the ratios line), and it loaded up as I wanted it to.

Marked as solved. Thank you for the reply.

cotti (felipecotti) said : #3

Hello. Sorry for bringing this up if I'm not supposed to, but I think this is the closest I can get to my situation.

I have built Terminator a couple of days ago, and the ratio setting did not work as expected. Everything just opens using half space.

I tried putting it as a line inside the childs on my personal layout. It's supposed to go there, right?