Terminator gui preference editor not opening

Asked by ashwin on 2013-08-16

I have installed terminator in Arch Linux and awesome wm. I dont see any way to open GUI preference editor. Can you please tell how to fix this ? As far as i remember i dont have most of the gnome packages. Will terminator not work without gnome packages ? My terminator is fully functional except that there is no option to open the preference editor.
My terminator version is:
terminator 0.97-1
I have all its dependencies installed like:
vte pygtk xdg-utils python2-notify python2-keybinder2

Question information

English Edit question
Terminator Edit question
No assignee Edit question
Solved by:
Stephen Boddy
Last query:
Last reply:

When you right mouse click on a terminal (not the titlebars), do you get a popup menu?

If so there should be a "Preferences" entry near the bottom. Are you saying that you a) get no menu, b) the menu does not have a "Preferences" entry, c) when clicked the entry does not open a "Preferences" dialog, d) something else?

The preferences does use the glade library to build the GUI from an XML file, but without more info of what you see and do, it's hard to say what is happening.

ashwin (ashwin-chn) said : #2

Thanks Stephen Boddy, that solved my question.

ashwin (ashwin-chn) said : #3

Stephen , I was clicking on the titlebar looking for menu. Didn't know that right click on body of the terminal opens the preference menu. Thanks.

Yeah, we need a better manual... scratch that. We need a manual :-)