System broadcast messages not showing in terminator 0.96

Asked by gman414 on 2011-12-23

In Ubuntu Oneiric (11.10) , system broadcact message such as those generated by shutdown are not showing up in terminator (0.96). System broadcast message seem to work fine in gnome-terminal. Running 'mesg' in terminator returned a 'y'. Any Ideas as to why the broadcast message are not showing up in terminator?. Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Terminator Edit question
Assignee:
No assignee Edit question
Solved by:
David Caro
Solved:
2012-01-09
Last query:
2012-01-09
Last reply:
2012-01-05
David Caro (dcaro) said : #1

The problem is caused by python vte not updating the utmp and wtmp logs (not sure neither if it must do so).
I've dona a fast search for a python lib to edit (not just read), those data structures, but I didn't find any...

I'll keep searching.

David

David Caro (dcaro) said : #2

Mmm, I looked into the code and vte function fork_command() has the parameters logutmp and logwtmp set to true... maybe a bug of vte library?

David Caro (dcaro) said : #3

found this.... http://forums.gentoo.org/viewtopic-t-884434-start-0.html

Also tried to run a vte terminal directly from the interactive python, and I was unable to update the wtmp and utmp recods (even as root).

>>> import vte
>>> import gtk
>>> w=gtk.Window()
>>> t=vte.Terminal()
>>> w.add(t)
>>> w.show_all()
>>> t.fork_command(logutmp=True, logwtmp=True, loglastlog=True, command='/bin/bash')
26355
>>> t.fork_command(logutmp=True, logwtmp=True, loglastlog=True, command='/bin/bash')
>>> vte.__file__
'/usr/lib/python2.7/dist-packages/gtk-2.0/vtemodule.so'

David Caro (dcaro) said : #4

Found the bug on launchpad :)

Best David Caro (dcaro) said : #5

And it has a workaroud that works for me:
Workaround:
# cd /usr/lib
# sudo ln -s libvte9 vte

gman414 (gman414) said : #6

The workaround works for me as well. Thank you

gman414 (gman414) said : #7

Thanks David Caro, that solved my question.