Broadcast to all terminal repeated character

Asked by Gin Tan on 2010-08-06

Terminator started to have problem lately when I tried to broadcast command to all terminals.
It was fine after the first installation and I like it so much and really want to keep using it.
Problem is it keeps repeat whichever character that I typed on the other terminals.

For example,

First terminal:
[gt-pc 11:29am ~] hostname

All the other terminal will have this:
[gt-pc 11:29am ~] hhoossttnnaammee

I have removed ~/.config/terminator and re-installed terminator but problem remains.

I created another user account and ran terminator with broadcast all, no problem at all.

So it's only my login. I have a feeling it's could be gnome config, but I don't know what should I look for.

If no one can help me out here, I have to clean up all my profile, but this will only be my last resort.

I am using Fedora 13, kernel 2.6.33.6-147.fc13.x86_64

Version: terminator-0.93-1.fc13.noarch

Thanks in advance.

Question information

Language:
English Edit question
Status:
Answered
For:
Terminator Edit question
Assignee:
No assignee Edit question
Last query:
2010-08-06
Last reply:
2015-03-09
Chris Jones (cmsj) said : #1

This is fascinating. I've seen these reports before and they too were not able to reproduce it with a fresh user.

Chris Jones (cmsj) said : #2

(I'd love to get to the bottom of the problem, but I have no idea what could be causing it, annoyingly. Perhaps create a new user and rsync over ~/.gconf/, then log in as the new user and see if it still happens?)

Angus Salkeld (asalkeld) said : #3

Hi

I did the following to work around the problem:

mv ~/.config/ibus ~/.config/ibus-saved

-Angus

Steven Nguyen (stnguyen90) said : #4

I tried to remove my terminator config and also moving the ibus folder, but I still have this problem. The problem I have is:

1. open two windows or tabs
2. change one terminal to broadcast to all
3. hit a key such as 'a'
4. all other terminals then show 'aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa'

Anyone else figure out why this is exactly happening?

Senninek (senninek) said : #5

I have very the same issue with Ubuntu 14.04. When I am trying to broadcast command to group of terminals or to all of them I get character repeated (sometimes only twice - when I put 'ls' I got 'llss', sometimes it just hangs my terminal with repeated only one letter over and over again).

Having exactly the same problem, using Ubuntu 14.10

Tried a lot of things.
~/.config/ibus renaming did not help
New user created, same problem
While terminator was having the problem I could reproduce a solution with "killall ibus-daemon"; without restarting terminator program the behavior was normal after the killall.
Found System Settings --> Language Support --> Keyboard Input Method System : None, then restart your session (logout/login), then problem was solved.

Don't know implications of this configuration change, but it seems to work without hacking.

Metin OSMAN (mosmanmix) said : #8

Hi,

quite an old issue, but I got this upgrading from 18.04 to 18.10.

Confirming the solution proposed by Bert van der Horst still works.

Metin

Can you help with this problem?

Provide an answer of your own, or ask Gin Tan for more information if necessary.

To post a message you must log in.