Build issues on elementary OS Luna

Asked by Adrian Geuss on 2015-01-06

Does Taxi support elementary OS Luna?
I get these errors when building Rev. 136:

taxi/src/Frontend/Widgets/FilePane.vala:157.22-157.36: error: The name `get_file_type' does not exist in the context of `G'
                    (b.get_file_type () == FileType.DIRECTORY)) {
                     ^^^^^^^^^^^^^^^
taxi/src/Frontend/Widgets/FilePane.vala:158.28-158.37: error: The name `get_name' does not exist in the context of `G'
                    return a.get_name ().collate (b.get_name ());
                           ^^^^^^^^^^

CMAKE output:

-- The C compiler identification is GNU 4.6.3
-- The CXX compiler identification is GNU 4.6.3
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- checking for modules 'gtk+-3.0;granite;libsoup-2.4'
-- found gtk+-3.0, version 3.4.2
-- found granite, version 0.2.3.1
-- found libsoup-2.4, version 2.38.1
-- Found Vala: /usr/bin/valac
-- checking for a minimum Vala version of 0.16
-- found Vala, version 0.26.1.9-22126
-- GSettings schemas will be installed locally.
-- GSettings shemas will be compiled.
-- GSettings schemas will be installed into /usr/share/glib-2.0/schemas/
-- Configuring done
-- Generating done

Question information

Language:
English Edit question
Status:
Answered
For:
Taxi Edit question
Assignee:
No assignee Edit question
Last query:
2015-01-06
Last reply:
2015-01-07
Kiran Hampal (khampal) said : #1

Hi Adrian,

Sadly Taxi does not support Luna, mainly due to the fact that Taxi requires newer dependencies (eg GTK+3.12). However Taxi will work on elementary Freya and Fedora 20/21 (and possibly other modern distros.)

Hope this answers your question. :)

Kiran

Can you help with this problem?

Provide an answer of your own, or ask Adrian Geuss for more information if necessary.

To post a message you must log in.