New task creation consumes unusual amount of (CPU?) resources

Asked by Lance on 2015-02-23

I just started using Task Coach, and each time I create a new task and save it, there is a lag of 5 seconds or so while the main Task Coach window apparently assimilates the new task. I can't create another new task, or access Task Coach at all during that time. If I try, I get an hourglass mouse pointer and "(Not Responding)" shows up in the window heading.

I had had "auto-save after each new action" or whatever it is, and assumed that was causing the delay, but I turned that off and it's still happening. Do you know why this is, and if there's anything I can do about it? I'm really loving everything about Task Coach so far, but I can't have such a core tool hanging up on me so frequently, so I'm nervous about committing to it. :-(

Question information

Language:
English Edit question
Status:
Solved
For:
Task Coach Edit question
Assignee:
No assignee Edit question
Solved by:
Lance
Solved:
2015-02-26
Last query:
2015-02-26
Last reply:
2015-02-25
Jérôme Laheurte (fraca7) said : #1

Looks like a serious performance problem... What is your operating system ? I know Task Coach is slow as hell on older Macs but on other platforms, with auto-save disabled it should not be this painful.

Lance (lance-w) said : #2

Hi Jérôme,

Thanks for your reply. I'm running Windows 7, but I seem to have resolved the problem. I updated Java, and now there is no more delay when creating or saving new tasks. Yay! :-)

Thanks again, and sorry to bother you with this.

– Lance

Jérôme Laheurte (fraca7) said : #3

The java update is probably a red herring; Task Coach is written in Python and we do not interface with anything Java... Anyway glad it's solved.