iPhone sync issue: connecting.....

Asked by Stead Kiger on 2012-10-24

I am having a problem syncing my iPhone to Task Coach on Windows XP. The iPhone is connected to an ad-hoc wireless network run from the Windows box. I can see the Task Coach Bonjour service from the iphone using the Discovery-Bonjour browser (http://itunes.apple.com/us/app/discovery-bonjour-browser/id305441017), which seems to indicate that it is on port 4096 (it lists myMachineName.local:4096 and wireless IP address below). I can also see the service from the Task Coach app. But when I try to sync, it shows "Connecting..." for a long time, maybe 2 minutes, and then gives a connection error message.

The connection error message asks me to check my settings, that Task Coach is running on the remote host, and the firewall settings. The problem seems not to be the firewall, since it occurs with the firewall off.

I connected and synced successfully a few times earlier today. (Presumably that is why it does not ask me for a password now.) But now, after disconnecting the adhoc network and then re-establishing it, I can not sync.

I'd appreciate any advice.

Thanks!

Question information

Language:
English Edit question
Status:
Open
For:
Task Coach Edit question
Assignee:
Jérôme Laheurte Edit question
Last query:
2013-01-02
Last reply:
2012-11-10

This question was reopened

Jérôme Laheurte (fraca7) said : #1

Could you try reinstalling the iPhone app ? Some users have reported success doing this, though I don't understand why...

Stead Kiger (wskiger) said : #2

Thanks for the advice. I tried reinstalling several times but was not successful synchronizing until I rebooted my iphone (by holding both the home button and the lock button at the top) between deleting and reinstalling Task Coach. Just powering it off (by holding down the lock button and then swiping) between deletion and re-installation didn't seem to do the trick. The first few times I reinstalled Task Coach, it didn't ask me for a password when I tried to sync, which makes me think that all of the application data (perhaps in the keychain) wasn't actually cleared in those first several times that I reinstalled it.

Thanks for your help and thanks for making a great piece of software!

Stead Kiger (wskiger) said : #3

Well, perhaps I spoke too soon. Not too long after I wrote comment #2 above, the synchronization issue came back. Reinstallation again solved the problem, but Task Coach strangely did not ask for a password this time.

Aaron Wolf (wolftune) said : #4

just a thought: perhaps you could try turning off the iPhone sync on the desktop side at the same time as you start everything else fresh. Then after you are started fresh, engage the iPhone sync on the desktop side and restart that. Also, use a password on the two devices that does not have any strange characters.

Stead Kiger (wskiger) said : #5

I think I can provide some more useful information about the problem now:

The synchronization issue appears to be caused by abruptly disconnecting (e.g., by walking out of range) my iPhone from the ad hoc wireless network (regardless of whether or not Task Coach is running on my iPhone at the time of disconnect). When I reconnect to the ad hoc wireless network, I'm unable to sync. However, after rebooting my iPhone and connecting to the ad hoc wireless network, I'm able to sync. Also, I think it may be necessary to restart Task Coach on the desktop side at the time of iPhone reboot.

No strange characters in the password BTW.

I'm running iOS 6.0.2 on an iPhone 5 and Windows XP on the desktop side.

Jérôme Laheurte (fraca7) said : #6

That's really strange. I'll try to reproduce this using the same configuration as you, if I can get my hands on a Windows box with a wireless controller...

Stead Kiger (wskiger) said : #7

Yesterday, I changed the configuration of my ad hoc wireless network from assigning IP addresses using DHCP to static IPs because it took a long time to reconnect in all of the testing and troubleshooting that I was doing.

After making the switch to static IPs, I've not had any trouble syncing--the problem has disappeared.

Whether or not to mark this problem as solved, I will leave to the development team to decide.

I do think that it may be helpful to users to edit the faq question on iPhone/iPad sync
(http://answers.launchpad.net/taskcoach/+faq/1401) to include some of these findings (i.e., avoiding DHCP for ad hoc networks) or at least a link to this discussion.

Thanks for your help!

Jérôme Laheurte (fraca7) said : #8

Thanks for the follow up. I'll try to reproduce the problem first so I can be sure of what happens.

Can you help with this problem?

Provide an answer of your own, or ask Stead Kiger for more information if necessary.

To post a message you must log in.