Cannot connect

Asked by Chris King on 2012-06-27

Hello,

I am trying to get tangerine working on my ubuntu machine. The service starts and seems to work fine. I can access the share from the server machine in banshee just fine.
However when I try to connect to it using another machine connected to the network I get this message from banshee

[Warn 11:45:22.716] Caught an exception - System.Net.Sockets.SocketException: Connection refused (in `System')
  at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remoteEP) [0x00000] in <filename unknown>:0
  at System.Net.WebConnection.Connect (System.Net.HttpWebRequest request) [0x00000] in <filename unknown>:0
System.Net.WebException: Error: ConnectFailure (Connection refused) (in `System')
  at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
  at System.Net.HttpWebRequest.GetResponse () [0x00000] in <filename unknown>:0
  at Daap.ContentFetcher.FetchResponse (System.String path, Int64 offset, System.String query, System.Net.WebHeaderCollection extraHeaders, Int32 requestId, Boolean disableKeepalive) [0x00000] in <filename unknown>:0
  at Daap.ContentFetcher.Fetch (System.String path, System.String query, System.Net.WebHeaderCollection extraHeaders, Int32 requestId) [0x00000] in <filename unknown>:0
  at Daap.ContentFetcher.Fetch (System.String path) [0x00000] in <filename unknown>:0
  at Daap.Client..ctor (System.Net.IPAddress address, UInt16 port) [0x00000] in <filename unknown>:0
  at Daap.Client..ctor (Daap.Service service) [0x00000] in <filename unknown>:0
  at Banshee.Daap.DaapSource.<Activate>m__7 () [0x00000] in <filename unknown>:0

I have tangerine setup to accept up to 10 users without a password however I still get a connection refused. Have you seen this before?
Is there a way to run tangerine through the command line using a -v flag so you can see why its rejecting incoming connections? Or if its seeing the incoming connections at all?

I look forward to hearing from you about this.

Thanks

Chris

Question information

Language:
English Edit question
Status:
Solved
For:
Tangerine Edit question
Assignee:
No assignee Edit question
Solved by:
Chris King
Solved:
2012-06-27
Last query:
2012-06-27
Last reply:
Chris King (1n3rw) said : #1

It was the stupid daap client not the server. Sorry. If I could delete this I would