Is tacker 0.6.1.dev37 compatible with python-novaclient <7.1.0 ?

Asked by Gianpietro Lavado on 2017-02-14

Would like to know if tacker 0.6.1.dev37 is compatible with any python-novaclient version older than 7.1.0

Yesterday I upgraded tacker, and it pulled the latest python-novaclient (7.1.0). Thing is, it seems the version has a bug with horizon (Newton), documented here: https://bugs.launchpad.net/horizon/+bug/1661456

So basically, my tacker upgrade broke nova-related tasks in horizon.

Now I'll move back to an older version of python-novaclient, but would like to know if there's any restriction that would affect tacker 0.6.1.dev37.

Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
tacker Edit question
Assignee:
No assignee Edit question
Last query:
2017-02-15
Last reply:
2017-02-28
Ali Baba (marhawa10) said : #1

dfgdgd

Why is my question invalid?

Sridhar Ramaswamy (srics-r) said : #3

Looks this was changed inadvertently to invalid, without any explanation. Switching it back

Thanks Sridhar. I had to downgrade manually to python-novaclient 6.0.0 due to its bug with Newton & Horizon v10, tacker seems stable but will keep adding tests. Would be ideal to know why v0.6.1 demands novaclient 7.1.0.

yong sheng gong (gongysh) said : #5

I think the main reason is the global requirements are upgrading novaclient, so to avoid the version conflict among openstack
components, the upgrade is pushed into tacker.

Tacker needs nova client because tacker test codes are using it. the main feature codes do not depend on it.

Can you help with this problem?

Provide an answer of your own, or ask Gianpietro Lavado for more information if necessary.

To post a message you must log in.