is there any work happening on this? It seems like a lot of the parts are there, just needs someone to put them together...

Asked by sanktnelson

Is there any life in this project? It seems like all the parts are there, described (for the x61t in particular) at thinkwiki and
Putting together a package that enables all these in one shot would be a great start..

Question information

English Edit question
Tabuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
SaintDanBert (saint-grillongroup) said :

I seem to be the primary shaker here:

GURU -- general understanding reasonably useless.

Expert -- EX is a has-been, Spirt is a drip under pressure

I'm working toward an update to a more recent Ubuntu and replacement
of my drive with something larger and faster. This informs my primary need
to get intellectual ownership and technical ownership of the tablet space.
As delivered, my Raven Tablet worked at about 80%. This was enough
to leave me happy, but shy of a place that leaves me satisfied. [Hmmm,
can that ever happen?]

Here are some troubles as-built:
== wifi LED does not work
== cannot hot-swap the ultrabase DVD for an ultrabase HDD
== cannot hot-swap the ultrabase HDD for an ultrabase DVD
== fingerprint reader does not play well with PAM et al
== stylus-pointer-tablet parts do not play well with 3D desktop anything
== lots of Gnome and KDE applications and utilities do not play well with CellWriter
== various issues with hardware buttons vs. X11 (or something) when in "tablet mode"

Are you interested in working with Ubuntu Jaunty or even Kaola to pull together most of
the tablet parts as one of those "meta-package" things? These are not true packages but
a list of dependencies and place holders ... "Install this package to get all of these parts
that are not yet integrated into a true package..."

At the risk of repeating repetition, here is my situation:

EmperorLinux Raven Tablet-PC
(Lenovo Thinkpad X61 Tablet-PC)
Dual Boot -- pre installed
    Ubuntu Hardy Heron (v8.04.3 LTS)
    Windows-XP/Pro Tablet Edition

Lots of RAM and Disk with the Ultra-base port replicator side-car.

Revision history for this message
SaintDanBert (saint-grillongroup) said :

I've upgraded to Karmic (v9.10) because it looked like more things would work on the tablet.
Sadly, more things are broken or simply do not work.
I would appreciate some feedback from this group telling me how to sort things out.

When I read elsewhere that some feature "just works out-of-box" but it does not work for me,
How am I supposed to proceed? Too often posts requesting information get snarky answers
"... worked for me, bump" if they get any answer at all.

Also, many of the troubles are in places where there is little or no documentation. Even the man
pages are place holders or point to out of date web pages.

I don't want to be a whiner or win-dozer here, but could likely solve some of my problems if only someone
could give me a nudge in the right direction.

Is anyone listening in the tablet community?
~~~ 0;-Dan

Revision history for this message
sanktnelson (launchpad-maibaums) said :

It's been a while since I upgraded to karmic, so I don't remember all the details of what was broken or what I did to make it work, but if you tell me what you're having problems with I can dig through my config files for likely solutions. Aside from automatic screen rotation things actually work better for me now than on previous versions.

Revision history for this message
SaintDanBert (saint-grillongroup) said :

thanks for being willing to help!!! Let's begin with an easy one that is a serious pain in my productivity.

Neither SLEEP (suspend-to-ram) nor HIBERNATE (suspend-to-disk) work. Using the panel menu "Hibernate" or "Sleep"
selection, things spin down to a blinking "new moon" LED. HIBERNATE does not turn off the computers.
The only way to restart the computer is with POWER_DOWN and COLD_START. On restart there is no indication of any sort of "resume" activity.

I've tried to read all sorts of logs only to see "success" and "ok" without errors. I confess that I don't know what I'm looking for.

I'm running out-of-box Karmic "generic-pae" kernel from the update manager. I've also applied all of the updates that have appeared for my installed software base.

My hardware is an Emperor Raven Tablet (Thinkpad X61-tablet) with 4GB ram and 500GB drive. I dual boot Win-XP and Karmic.We can continue here, or we can go private while we negotiate what is going on if you want. I don't think pages of raw try ... how about ... what if ... helps many people. Tell me what you want to know (and how to discover that in some cases) and I'll report back. I'll post a cogent "answer" once we sort things out.

Thank you again.
~~~ 0;-Dan

Revision history for this message
jim (adamskijl) said :

I would like to help! You can find me at <email address hidden>. I currently teach application development and database theory at Walla Walla Community College in Washington State, USA. I am on FaceBook and Twitter not much. I am in the midst of ridding myself of Windows in favor of Karmic. Which I truly love after trying a number of distros.

My first take for Linux on Laptop is this:

Whenever I investigate posts of the tablet PC's I find two consistent themes.... Debian based operating systems like Mepis seem to have IBM Thinkpad support so there should be something basic to adapt to when it comes to docking stations and basic hardware. Specialized distros like SuseLinux has most of the tablet settings down if two conditions apply. The tablet is more than two years old as of today and the distro itself has gone corporate (think Suse and Redhat). But tablets are a moving target as I learned the hard way on my Lenovo x200 tablet.

1- Lenovo changed fingerprint reader hardware so good bye to fp reads.
2- The buttons for screen rotation can be detected with linux cli tools so it must be just a matter of programming the X config file.
3- The following URL's were the most helpful to me. You probably have already seen them.

Revision history for this message
Will R (dawnbandit) said :

If you want to help me plan a Newer Tabuntu made by myself I would REALLY appreciate the help, you can access it at

Revision history for this message
Will R (dawnbandit) said :
Revision history for this message
kevin malone (kevinmalone01) said :

Solutions when Quickbooks database server manager stopped- firstly, run Quick fix my program from Quickbooks tool hub and if you don't have Quickbooks tool hub then you have to download and install it then from the tool hub run Quick fix my program. Secondly, repair your Quickbooks desktop installation. The third solution is to run the clean install toll from the tool hub. The next solution is - suppress the Quickbooks desktop application. Another solution is to run the Quickbooks Install diagnostic tool from the tool hub.

Revision history for this message
andrew moore (andrewmoore01) said :

Solution for Quickbooks database server manager windows firewall is blocking QuickBooks- Firstly configuring firewall ports- to do so firstly open the Quickbooks database server manager then click on the monitor tab then note the port number listed on your application, to open settings- click Windows+I keys together then click on update and Security option then select the Windows security option from the left side and then click on firewall and network security option after that select the advanced settings option from the list then a new window will open then click on the inbound rules option and select the new rule option then select the post and click on next then click the TCP and select specified local ports option. Different Port Numbers are depending upon the version that you are using then click on Next and select Allow the Connection then select next and make sure that all three options are selected again click on next and give a name to the new rule then after writing a name select next then select finish. Repeat the above process for “Outbound Rule” and check that the error still exists.

Can you help with this problem?

Provide an answer of your own, or ask sanktnelson for more information if necessary.

To post a message you must log in.