Unable To Create Live System, "Create New" Button "Greyed" Out

Asked by Dave on 2015-12-14

Hi,

I have installed the latest Systemback on a new PC build.
I have done what I always do.
Install OS, Linux Lite(Ubuntu 14.04 based), do initial distro updates and basic system config.
Then install Systemback, installed O.K

Then use Systemback to create an initial "Restore point".
That worked O.K (16GB USB stick, that tests O.K)
Then I went to the "Live System Create" page.
But the "Create New" button is "greyed" out, so unable to create live.??

The only difference on this build is it is "multi-boot" with Windows7, could this be the issue..??

Question information

Language:
English Edit question
Status:
Solved
For:
Systemback Edit question
Assignee:
No assignee Edit question
Solved by:
Dave
Solved:
2015-12-15
Last query:
2015-12-15
Last reply:
2015-12-14
Dave (xwebsubs) said : #1

update...
I have just found another post that indicates it might be kernel related..??
I'm using kernel 4.2.0

Kendek (nemh) said : #2

Yes, probably the problem is the kernel. If the current kernel does not contain aufs, overlayfs or unionfs support, or the unionfs-fuse package (very slow solution) is not installed, the button is disabled.

Dave (xwebsubs) said : #3

Hi Kendek,

Many thanks for the quick response...
I have looked in my package manager "synaptic", The nearest things I have is the following:

> aufs-tools = Tools to manage aufs filesystems
> aufs-tools-dbg = Tools to manage aufs filesystems (debug)
> overlayroot = Use an overlayfs on top of a read-only root filesystem
> unionfs-fuse = Fuse implementation of unionfs

David

Dave (xwebsubs) said : #4

Hello Kendek,

After searching it appears that "overlayfs" is included in kernel 4.2.0

I can try the the unionfs-fuse package,
see if that works, and how long it takes

Kendek (nemh) said : #5

The aufs and the unionfs are available as kernel patches, the overlayfs is selectable in the main kernel tree. But it is not obvious that your compiled kernel contains any of these, depends on the kernel configuration.
To be sure, the default Ubuntu kernel is good for the Live systems. In the 14.04 repository:
3.13.0-71
3.16.0-55
3.19.0-39
4.2.0-19
See the /boot/config-* file:
CONFIG_AUFS_FS=m
CONFIG_OVERLAY_FS=m

Dave (xwebsubs) said : #6

Hi Kendek,

I have checked.
Kernel: 4.2.0

In config file:
There are NO references to aufs_fs
and I see:
#CONFIG_OVERLAY_FS is not set

So I guess that is the cause.
I do not know enough to know if I can just edit the config file to:
CONFIG_OVERLAY_FS=m

Kendek (nemh) said : #7

Yes, this is the cause, and you need to recompile your kernel with overlayfs support. Or just install the Ubuntu kernel from the repository.

Dave (xwebsubs) said : #8

Hi Kendek,

Thanks...
I have no idea how to compile my own kernel.
I will try the unionfs-fuse option, see how(if) that works.

I will mark this closed(solved) in terms of knowing the issue.