add/remove application

Asked by owy1 on 2009-10-01

on system76 that I have for only a few weeks. Just did a reformat of a live cd 9.04 64bit. Was in process of adding apps and it must have not completed the process as I left the room. When I came back this AM the following error is there:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure a' to correct the problem.
E:_cache>open()failed,please report.

Please tell me step by step how to correct this problem.

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
System76 Edit question
Assignee:
No assignee Edit question
Solved by:
Thomas Aaron
Solved:
2009-10-01
Last query:
2009-10-01
Last reply:
2009-10-01
Thomas Aaron (tom-system76) said : #1

Please make sure you have a wired internet connection. Then open a terminal (Applications > Accessories > Terminal) and run the following command...

sudo dpkg --configure a

hopestar (lrsinger2) said : #2

The following problem was encountered:
dpkg: error processing a (--configure):
 no package named `a' is installed, cannot configure
Errors were encountered while processing:
 a

Thomas Aaron (tom-system76) said : #3

Ah...

You actually typed the error message incorrectly. You will need to run...

sudo dpkg --configure -a

hopestar (lrsinger2) said : #4

umm what do i do after I type that?

Thomas Aaron (tom-system76) said : #5

It might prompt you for your password. But that should be it.

Best Thomas Aaron (tom-system76) said : #6

You can go ahead and run updates again.

owy1 (lori-singer) said : #7

Thanks Thomas Aaron, that solved my question.