sound recording not working

Asked by Corey Abshire on 2009-05-18

Hi system76!

I'm having some trouble recording sound on my new Wild Dog.

I'm using an external mic, which I know is good because it works fine on all the other computers I've tried it on.

I've tried it in several applications, but the main one I'm trying it in at this point is the Gnome sound recorder app. I checked a couple of the other system76 posts related to sound, and while they were mostly laptop oriented, I tried the advice there and still no joy.

I'm using I believe all the default settings, and I even just tried reinstalling the drivers and rebooting and I'm still unable to hear anything.

A few things that I found odd that may be useful:

1. When I received my machine, the CD-ROM was not working properly, it would spin up, but it would never register any disks. When I opened the machine to inspect, I found that the data cable was not even connected, but the power cable was. After I connected the cable and restarted it worked. Also, the hard drive was not seated in its cage. Instead, it was laying at the bottom of the case. I was able to seat it in its cage I think properly and have not seen any issues from it. This all leads me to believe that maybe my system was shipped before it was complete, and maybe something else is not connected inside the system, even though I did not see any other obvious unconnected cables.

2. On some of the other posts, the "Record from input:" field in the sound recorder seemed to have more options, such as "Mic". The only option mine has is "Capture". When I open up the volume control, I can see "Capture", "Mic", "Front-Mic", etc..., and I can unmute them and turn them all the way up, but still the sound recorder doesn't pick anything up.

I've tried using audacity, and ardour as well, but no luck there either in anything I try, so, going to have to hopefully see if you can help me out.

Thanks!
 - corey

Question information

Language:
English Edit question
Status:
Solved
For:
System76 Edit question
Assignee:
No assignee Edit question
Solved by:
Thomas Aaron
Solved:
2009-05-19
Last query:
2009-05-19
Last reply:
2009-05-19
Best Thomas Aaron (tom-system76) said : #1

Hi, Corey.

Let's move this to support email so that I can send you some screenshots...

support(at)system76(dot)com

Corey Abshire (corey-abshire) said : #2

Thanks Thomas Aaron, that solved my question.

Eli Dupree (elidupree) said : #3

Hi - I'm also having a sound recording problem. I have a new Darter Ultra (Ubuntu 9.04.)

Like Corey, I only have the "Capture" option in the Sound Recorder program's "Record from Input" field. I've gone into the sound preferences and unmuted everything and turned the volumes up (including on Capture), but it still didn't record, although when I turned up the "Capture" volume, it started recording some low-volume white noise that wasn't affected by any noise near the built-in mic.

Corey Abshire (corey-abshire) said : #4

Hi Eli. Tom helped me solve this over email. I think the key for me was changing the "Digital Input Souce" in the Alsa mixer settings. For some reason by default that doesn't even show up in the mixer so you may have to open up the mixer preferences and turn that option on. Once you do, you should see an options tab with a digital input source setting. I think when I changed that to "Analog Inputs" is when everything started working. - corey

Eli Dupree (elidupree) said : #5

Cool - got it working!

(When I went to the mixer preferences, it let me enable an option called "Input Source" (not "Digital Input Source").The option was set to "Mic"; setting it to "Front Mic", which was the only other option, made the recording work. Presumably if I plug in an external mic, I'll have to set it back in order to use that...)