panp4 won't start up

Asked by trenschler

Hi, I've had my Pangolin Performance laptop for about 3 months now. I believe it is a panp4i. I am running Hardy (8.04.1). My hardware configuration is: Core 2 Duo P8400, 4 GB DDR2 and 320 GB 5400 RPM SATA II. No Nvidia graphics card.

At first I had problems with the system randomly freezing up while I was working. Typical programs running are Firefox, Eclipse and a terminal window. Sometimes also a Nautilus window. This freeze up happened a couple of times over the course of a couple of weeks. I would have to do a hard shutdown and reboot. In the last couple of days, this has become more frequent and when I'd try and reboot, nothing at all happened. I found that I could press Fn+F7 and then the BIOS screen would appear and it would boot. Now even that doesn't work. I've turned the machine on and variously tried all of the Fn+F? combinations to no avail, all I get when I power up is a dark screen.

I suspect a BIOS issue or a hardware problem. What should I do next.


Question information

English Edit question
System76 Edit question
No assignee Edit question
Solved by:
Thomas Aaron
Last query:
Last reply:
Revision history for this message
Thomas Aaron (writer-programmer) said :

When do you get the dark screen? Do you see the manufacturer splash screen or the post screen? Are you getting as far as the grub countdown (grub...3...2...1...)? Do you end up with a flashing cursor? Basically, I need to understand precisely where in the boot-up process it is failing.

The freezing is caused by a bug in the driver for the intel 4965 wireless card. It can be fixed by running this command from a terminal...

sudo apt-get install linux-backports-modules

It could be that all of the hard power-downs has hosed your file-system, and your computer is no longer finding grub. We may also need to re-set your cmos (if it is not even getting to the manufacturer splash screen or post).

Revision history for this message
trenschler (trenschler) said :


I see nothing at all. I hear the system power up the CD and hard disk but nothing ever appears on the screen. The CMOS reset sounds like what we need to do. I had a similar situation on a desktop system a couple of years ago.

Thank you!

Revision history for this message
Thomas Aaron (writer-programmer) said :

Remove your battery and ac adapter.
Remove the largest panel on the bottom of your computer.
Remove your memory cards.
Near the memory sockets, there is a white connector on the motherboard; it has a red wire and a black wire going into it.
Remove that connector, wait for about 2 minutes and replace it.
Re-install your memory cards.
Connect only the ac adapter.
Turn your computer on.

Does that fix it?

Revision history for this message
trenschler (trenschler) said :

Unfortunately, this did not help. I get the same results as before.

Revision history for this message
Best Thomas Aaron (writer-programmer) said :

Please contact me at support(at)

Include your order number or the name under which the computer was purchased.
Also include the serial number on the bottom of the computer that starts with "88...".

I'll arrange to bring it in for warranty repairs.

Revision history for this message
trenschler (trenschler) said :

Thanks Thomas.

Revision history for this message
trenschler (trenschler) said :

Thanks Thomas Aaron, that solved my question.