Pangolin Laptop Webcam Manufacturer

Asked by Bruce Bigby on 2008-10-10

Does System76 use a proprietary driver to get the webcam to work with applications like ekiga? I tried ekiga under Fedora 9, but ekiga didn't work with the webcam. I would like to get my webcam working under Fedora 9, but I have no clue about where to start. I know that System76 ships with Ubuntu, but I would appreciate knowing a little more about getting this webcam working under Fedora 9. I had to abandon Ubuntu 8.0.4, because the problems that I had with mounting and unmounting USB devices, such as flash drives or my Nokia N800 tablet PC/PDA, were just too annoying. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
System76 Edit question
Assignee:
No assignee Edit question
Solved by:
Bruce Bigby
Solved:
2008-10-11
Last query:
2008-10-11
Last reply:
2008-10-10
Thomas Aaron (tom-system76) said : #1

Hi, Bruce.

You will need to download the code for the uvc webcam and compile it.

Here is essentially what we do to add support for your webcam. It should be fundamentally the same for Fedora. Of course, some of the commands (like apt-get and sudo work differently in Fedora).

https://help.ubuntu.com/community/UVC

Best,
Tom

Bruce Bigby (bbigby) said : #2

Thank you!

Bruce Bigby (bbigby) said : #3

Hi Thomas, I got the camera working under Fedora 9 by following, essentially, the instructions at https://help.ubuntu.com/community/UVC. The only difference is that I needed to install the following packages:

kernel-headers-`uname -r`
kernel-devel-`uname -r`

and I also had to modify the Makefile of the uvcvideo package so that,

INSTALL_MOD_DIR := kernel/drivers/media/video/uvc

My laptop is working perfectly with Fedora 9 now -- not something I could say about Ubuntu 8.0.4 (USB Issues).

Now if I could just get the NetworkManager to work with static addresses. For now, I totally disabled the NetworkManager service, and reenabled the standard network service. Unfortunately, my router doesn't enable me to fix a DHCP address to a specific MAC address, at least not without updating the firmware to a totally new open source one. I have one of those Linux-based Linksys routers, which is upgradable to an open source firmware. I'll have to deal with that some other time.

Thomas Aaron (tom-system76) said : #4

I'm glad you got it up and running.

Please feel free to provide me with any feedback pertaining to running Fedora on our computers. While we may never offer Fedora, we do have customers that prefer it, and I like to keep a little 'bag of tricks' handy for them.

Marc-Andre Gendron (mcgendron) said : #5

Hello,

I also installed Fedora on my Pangolin since I have to use certain software that supports Fedora. I followed this guide to get the webcam working, but it continues to not work. Whenever I try to test it with gstreamer-properties, it either gives me this error:

video for Linux 2 (v4l2): Device '/dev/video0' cannot capture at 1280x1024

or just quits completely.

Any ideas?

Hi, Bruce.

1. You have to press Fn-F10 to turn the webcam on.
2. Do you have your screen resolution set to 1280x1024? Do you get the error if you set it to 1280x800?
3. Does Fedora have "cheese" available in the repos? Try using that to test the webcam.
4. You might also set the Video plugin to noXV in gstreamer-properties and see if that helps.

Bruce Bigby (bbigby) said : #7

Hey, Thomas. You replied to the wrong person. 8-) Marc-Andre Gendron posted the previous inquiry. Anyway, I tried Cheese on my pangolin, and it works. ekiga also works. I'm not familiar with the gstreamer-properties utility. When I run it, it produces the following output:

gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'

I ran the video test once, and a rather large window appeared with my face on it. 8-) Then I closed it. On subsequent attempts, the window did not appear. Anyway, everything appears to work. However, I lost video capability at some point during a previous session, but I'm not sure exactly when. Rebooting made it recover. That's okay, I haven't used it to communicate with anyone yet.

Marc, just try using one of the camera applications. It may work regardless of whether gstreamer-properities works.

Bruce Bigby (bbigby) said : #8

One more thing for Marc-Andre: Did you run the following command as root?

/sbin/modprobe uvcvideo

or you can restart your laptop. I'm assuming that you are running Fedora, but I'm not sure which version. I'm running Fedora 9.