Starling Netbook-Wireless not working

Asked by Eric Jackson

I have been having a recent issue in regards to my wireless.
I can see the various networks that are available, however, I can't connect to any of them. Even the network in my house that is set to auto.


Question information

English Edit question
System76 Edit question
No assignee Edit question
Solved by:
Eric Jackson
Last query:
Last reply:
Revision history for this message
Thomas Aaron (tom-system76) said :

Thanks, Eric. Could you please try booting from a live Ubuntu USB flash drive, and see if you are able to connect from it? This will tell us whether or not your issue is hardware or software related.

Revision history for this message
Eric Jackson (eric.jackson) said :

I just booted Ubuntu a few times from a live USB drive.

Every time I did, I was unable to see any wireless networks. The computer I'm typing this on now is running off a wireless network, so I know the network works.

When I booted off my hardrive; I was able to see the wireless networks, but unable to connect to any of them.

Revision history for this message
Carl Richell (carlrichell) said :

Hi Eric,

It sounds like the wireless module is turned off. Try hitting FN+F11 to to turn on wireless. A small light should illuminate on the front of the Starling. Then try to connect again.



Revision history for this message
Eric Jackson (eric.jackson) said :

I've checked both from booting from a USB and from my hardrive that the wireless is turned On, but still no luck with making a working connection. It is the same situation.

-when booting from a USB it can't see any network
-when booting from my hardrive, it can see the network, but can't connect

There are two other anomalies that I want to point out;

One is that every so often there appears to be a graphical glitch (the only way I can explain it) on the indicator for wireless (on the screen, not the unit itself) a quick flash of white to the left of it. It comes by rather quick and random so I'm not able to say exactly what it is.

The other is that I was typing a document up while on the train (New York City Subways), there is no service of anything down there (no cell, nothing) I apparently picked up a wireless signal somewhere (possibly at a stop where there was a terminal or something) but the computer proceeded to tell me that there was a full signal all the way through the tunnels...something that is very odd..either a problem with the wireless, or a secret the MTA isn't telling anyone!

Revision history for this message
Thomas Aaron (tom-system76) said :

Hi, Eric. Could you please try one more time from a 10.10 Ubuntu live USB? It has come to my attention that the 10.04 version may not support the wireless card without updates.

You also should try turning your wireless card on with the function key and then rebooting the machine to see if that works. One tech mentioned he was able to see wireless networks with the card off but couldn't connect.

If that doesn't work, please call or email us at and we'll figure out the best next step.

Revision history for this message
Eric Jackson (eric.jackson) said :

I'm having some trouble booting from a live ubuntu 10.10 usb drive.
I'm not sure if its a problem with the drive or the computer. It keeps getting stuck at: [sdb] Attached SCSI removable disk

I'll try recreating the live drive and then booting from it.

What I did notice is that when I turn the machine on, the light for the wireless card is orange.

I just tried turning the wireless card on (via the fn+f11 key) and then rebooting and it did not solve the problem. I can see all the wireless networks in my vicinity-but I cannot connect to any of them.

Revision history for this message
Thomas Aaron (tom-system76) said :

Yes, that sounds like either a bad image or a bad burn to the USB disk.

Revision history for this message
Eric Jackson (eric.jackson) said :

I've tried several times to get the Starling to boot into 10.10 and it won't. I know the USB drive works as I was able to successfully boot into 10.10 from another computer.

Is there anything else I can do to find out whether the problem lies in the hardware or the software? I can connect the Starling to the internet via a physical connection, would I be able to download an update for the wireless that way?


Revision history for this message
Thomas Aaron (tom-system76) said :

Could you please contact our support department at 720-226-9269 x2. Ian has been briefed on the situation and is expecting a call from you. At this point, I think we can help you more efficiently over the phone.

Revision history for this message
Eric Jackson (eric.jackson) said :

The wireless issue was solved-however my issue with booting into 10.10 still remains (something I'm working on with Ian...who has been incredibly helpful during all of this)

The wireless issue was solved in a very strange way...but this might help anyone else who is having issues with the wireless.

I right clicked on the wireless icon in the panel and selected 'Edit Connections'

I went to the 'Wireless' menu and selected my home router which was set to auto. I deleted it from the menu...then connected to it again (resetting it to auto) it then connected...much to my surprise!

It's been working solidly for the past two issues yet.