wireless adapter no longer working

Asked by lisa litchfield on 2010-10-13

I have a Pangoline Performance laptop. The wireless worked fine when I got it, not problems at all. In that last week, it began disconnecting and reconnecting whenever it was on. I have troubleshot my home network wireless configuration, and the laptops and cannot find anything wrong. I have determined that the laptop has a wireless adapter with a driver, that the kernel can see the wireless adapter, and that the wireless adapter is working properly. I cannot, however connect to anything and can normally not even see the connections. If i right-click on the applet and disable the wireless, then enable it again, it will sometimes detect networks, try to connect, fail, and then the networks are gone from the list completely and the adapter sees nothing. I have also tried Fn + f11 to no avail. The indicator light on the front of my machine stays on. I brought the adapter down and up again also with no success and have run out of things I know of that I can try. Commands used to troubleshoot this issue include:

ifconfig wlan0 down
ifconfig wlan0 up
nm-tool
lshw -C network
lsmod
iwconfig (note that the signal level indicated with this command is "Signal level-0 dBm)
iwlist scan (note, scan turns up nothing "Scan completed: )
rfkill list (note, turns up nothing)

Question information

Language:
English Edit question
Status:
Answered
For:
System76 Edit question
Assignee:
No assignee Edit question
Last query:
2010-10-14
Last reply:
2010-10-14
lisa litchfield (litchfieldl) said : #1

The ONLY thing that turned up a little odd is the driver listed in lshw -C network was not identical to the driver listed in lsmod. The names were virtually the same, however.

Thomas Aaron (tom-system76) said : #2

Please try running this command...

lsmod

...and post the entire output here.

Also, please verify that this occurs on *other* wireless access points.

Please also try unplugging and re-plugging in your access point... even if other computers are working fine on it.

lisa litchfield (litchfieldl) said : #3

Thank you for your quick response. This issue occurs with any access point I have attempted to connect to. I have reset both my router and my cable modem several times in an attempt to remedy this without success. I have verified that all physical connections are solidly connected and in the correct place. I have also logged into my router and verified that its settings are correct and have not changed. Below you will find the output of lsmod.

Module Size Used by
binfmt_misc 7960 1
ppdev 6375 0
vboxnetadp 5171 0
vboxnetflt 15064 0
vboxdrv 1792440 2 vboxnetadp,vboxnetflt
dm_crypt 13043 0
joydev 11072 0
snd_hda_codec_atihdmi 3023 1
snd_hda_codec_realtek 279040 1
snd_hda_intel 25773 2
snd_hda_codec 85759 3 snd_hda_codec_atihdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 6924 1 snd_hda_codec
snd_pcm_oss 41394 0
snd_mixer_oss 16299 1 snd_pcm_oss
snd_pcm 87946 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 1782 0
snd_seq_oss 31219 0
snd_seq_midi 5829 0
snd_rawmidi 23420 1 snd_seq_midi
snd_seq_midi_event 7267 2 snd_seq_oss,snd_seq_midi
snd_seq 57481 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 23649 2 snd_pcm,snd_seq
snd_seq_device 6888 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
sdhci_pci 6700 0
snd 71187 16 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
r8192se_pci 489163 0
psmouse 64576 0
jme 31269 0
jmb38x_ms 8643 0
serio_raw 4918 0
mii 5237 1 jme
memstick 10121 1 jmb38x_ms
sdhci 17928 1 sdhci_pci
led_class 3764 1 sdhci
fglrx 2353486 31
soundcore 8052 1 snd
snd_page_alloc 8500 2 snd_hda_intel,snd_pcm
lp 9336 0
parport 37160 2 ppdev,lp
dm_raid45 75532 0
xor 4685 1 dm_raid45
ahci 37870 2
fbcon 39270 71
tileblit 2487 1 fbcon
font 8053 1 fbcon
bitblit 5811 1 fbcon
softcursor 1565 1 bitblit
video 20623 0
output 2503 1 video
vga16fb 12757 0
vgastate 9857 1 vga16fb
intel_agp 29095 0

Thomas Aaron (tom-system76) said : #4

Thanks. I'm pretty sure you have a bad wireless card. Please contact us at support...at...system76...dot...com for further instructions.

Can you help with this problem?

Provide an answer of your own, or ask lisa litchfield for more information if necessary.

To post a message you must log in.