Wireless repeatedly disconnects and reconnects

Asked by Federico Urban on 2010-10-12

I'm using Ubuntu netbook edition 10.04 (although I always use the gnome session) on the new staling netbook, and my wireless keeps disconnecting and reconnecting few minutes. Sometimes it goes for longer, even an hour, but at some point it loses signal only to find it again a few seconds later (in most cases). I tried different networks (in fact, I've been travelling the past few weeks and been connecting to around a dozen wireless networks) but the problem seems to be always there, sometimes alleviated, but I never have a steady stable connection. Notice that this problem seems independent on the strength of the signal (which, for instance, now is almost 100%) and not on whether the network is encrypted or not. What should/could I check for this to be solved? Thanks a lot.

Question information

Language:
English Edit question
Status:
Solved
For:
System76 Edit question
Assignee:
No assignee Edit question
Solved by:
Ian Santopietro
Solved:
2010-10-17
Last query:
2010-10-17
Last reply:
2010-10-15
Best Ian Santopietro (isantop) said : #1

Please press Fn+F11 to turn the wireless card off. You can check with the status of the wireless indicator light. It's the third one from the left on the front, left edge of the computer. It should be off. If it isn't, press Fn+F11 again until it does come off.

Now, please press it again to turn it back on. The light should be on. Give this a try.

jpeach (launchpadspam) said : #2

I have the same issue. I have upgraded to 10.10 and the issue continues.

Isantop, thanks for the answer but it is not related to the question. You provided instructions on how to manually enable/disable the wireless card. The problem here is that the netbook keeps dropping connection when it should not.

Ian Santopietro (isantop) said : #3

In the past, I have seen this issue resolve itself by simply powering off the wireless card, then powering it back up. Because of this, it makes a good first step. If this doesn't work for you, I'd be happy to give other suggestions.

jpeach (launchpadspam) said : #4

Isantop, are you saying that when the system locks up, you do the Fn+F11 step? No other keys on my system appear to be working. Thanks

Ian Santopietro (isantop) said : #5

Hi.

I'm sorry, I didn't realize your system was locking up. The original poster did not mention that that was happening to you, so I don't think you and him have the same issue. Please file a separate question on this, or email us at support...at...system76...dot...com

jpeach (launchpadspam) said : #6

I tried Fn+F11 and Fn+F10 and that did not solve the problem. I will open a different ticket. Thanks for your help

Thanks Isantop, that solved my question.