I cant, for the life of me, compile this thing due to dependencies

Asked by SilentWarrior on 2016-03-08

Hello.

I am trying to install this on my system. I have tried to compile it from source but I keep getting stuck on missing dependencies.

I have been installing them all one by one by hand but after much trying, i am still stuck on this ones:

configure: error: Package requirements ( glib-2.0 >= 2.40.0 gdk-x11-3.0 >= 3.0.0 gtk+-3.0 >= 3.0.0 gio-2.0 >= 2.40.0 gio-unix-2.0 gobject-2.0 gthread-2.0 gee-0.8 >= 0.5.2 json-glib-1.0 >= 0.10.0 keybinder-3.0 libnotify
  ) were not met:

No package 'json-glib-1.0' found
No package 'libnotify' found

I have installed all GTK3 and dev stuff, Vala and dev stuff too, numerous other little things but still cant get it to compile.

Can you provide me with a list of dependencies and their names so I can successfully compile and install this on Ubuntu 14?

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Synapse Edit question
Assignee:
No assignee Edit question
Solved by:
Rico Tzschichholz
Solved:
2016-03-08
Last query:
2016-03-08
Last reply:
2016-03-08
Best Rico Tzschichholz (ricotz) said : #1

The error message is pretty clear that development files for "json-glib-1.0" and "libnotify" are not available.
 aka libjson-glib-dev and libnotify-dev

Manfred Hampl (m-hampl) said : #2

There are PPAs with synapse for Ubuntu 14.04
see https://launchpad.net/~synapse-core and their PPAs

https://launchpad.net/~synapse-core/+archive/ubuntu/ppa
with 0.2.10-2ubuntu3
and
https://launchpad.net/~synapse-core/+archive/ubuntu/testing
with 0.2.99.1+bzr649~ubuntu14.04.1

Thanks Rico Tzschichholz, that solved my question.