Zeitgeist: All files are opened with nautilus

Asked by snoxu on 2012-04-12

I'm using the zeitgeist plug-in to open various types of files, when opening with the default application Synapse always opens them in Nautilus instead of opening them with the system's default app.

I'm experiencing the same problem with the Journal gnome shell extension.

Anyone know how this can be fixed?

Question information

Language:
English Edit question
Status:
Solved
For:
Synapse Edit question
Assignee:
No assignee Edit question
Solved by:
Michal Hruby
Solved:
2012-05-21
Last query:
2012-05-21
Last reply:
2012-04-15
Best Michal Hruby (mhr3) said : #1

Try wiping your ~/.local/share/applications

snoxu (snoxu3000) said : #2

Thanks that fixed it.

Should of thought of it earlier.

David Parker (cedardocster) said : #3

Can you elaborate on what "wiping your ~/.local/share/applications"

I imagine it means "delete everything in there" but there are a lot of files and folders in there and I'd hate to screw everything up.

Thanks

snoxu (snoxu3000) said : #4

I'm not currently using Synapse, but I believe the file in question is:

mimeapps.list

I could be wrong though and it«s the only file in the my ~/.local/share/applications.

 Also I believe deleting the file will reset all user wide program/file type associations.

David Parker (cedardocster) said : #5

I deleted the file and then all the files in that directory and neither worked.

Any further suggestions?

snoxu (snoxu3000) said : #6

I'm afraid I don't.

Michal Hruby's suggestion solved my issue. Maybe something else is going on on your system.

snoxu (snoxu3000) said : #7

Thanks Michal Hruby, that solved my question.