Make fails with "Package `gee-1.0' not found"

Asked by Lauri Kainulainen on 2011-02-20

Posting as a question as this seems more like a mistake on my part...

I'm using latest bzr (r365) on Ubuntu 10.10 32bit.

./configure passes fine, but make fails with

Making all in core
make[3]: Entering directory `/home/lauri/code/synapse-project/src/core'
  VALAC synapse-core.vala.stamp
error: Package `gee-1.0' not found in specified Vala API directories or GObject-Introspection GIR directories
Compilation failed: 1 error(s), 0 warning(s)

Vala is from Vala Team PPA:
$ valac --version
Vala 0.11.5

$ wajig list gee
ii gir1.0-gee-1.0 0.5.3-0ubuntu1 GObject based collection library - GObject-Introspection
ii libgee2 0.5.3-0ubuntu1 GObject based collection library
ii libgee-dev 0.5.3-0ubuntu1 GObject based collection library (development files)

Where can I find the correct libgee? Is there a PPA?

Thanks in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
Synapse Edit question
Assignee:
No assignee Edit question
Solved by:
Michal Hruby
Solved:
2011-02-20
Last query:
2011-02-20
Last reply:
2011-02-20
Best Michal Hruby (mhr3) said : #1

The gee package in Maverick is kinda broken, you need to make a symlink to the vapi (wherever it's installed) in /usr/share/vala/vapi.

Lauri Kainulainen (luopio) said : #2

Thanks for the quick reply! That indeed was the problem. Here's the actual command:

$ sudo ln -s /usr/share/vala-0.10/vapi/gee-1.0.vapi /usr/share/vala/vapi/

Lauri Kainulainen (luopio) said : #3

Thanks Michal Hruby, that solved my question.