https://launchpad.net/api/1.0/~swift-core/+archive/release url problem

Asked by Mehmet Hacısalihoğlu on 2013-09-27

Hi,

when I want to connect https://launchpad.net/api/1.0/~swift-core/+archive/release, I get error message "Cannot access PPA (https://launchpad.net/api/1.0/~swift-core/+archive/release) to get PPA information, please check your internet connection."
PPA isnot accessed. Can you help me please a.s.a.p?
And when I run "add-apt-repository ppa:swift-core/release" command, same error message.

Regards.

Question information

Language:
English Edit question
Status:
Answered
For:
OpenStack Object Storage (swift) Edit question
Assignee:
No assignee Edit question
Last query:
2013-09-30
Last reply:
2013-09-30
gokhan (gokhankcmn) said : #1

I have the same problem too.

Monty Taylor (mordred) said : #2

Hey! The swift-core ppa had been deprecated for about 2 years and has not received updates for some time. It was recently removed.

Out of curiosity can you tell me if this is a new install you were doing and if so where you were pointed to the ppa? I'd like to make sure documentation is up to date.

OpenStack no longer produces pacakges, but Ubunutu is producing packages itself. You probably want to look at the Ubuntu Cloud Archive:

https://wiki.ubuntu.com/ServerTeam/CloudArchive

Which has recent OpenStack for previous Ubuntu releases.

I have to Ubuntu Server 12.04 release. And Instructions for a Multiple Server Swift Installation document(http://docs.openstack.org/developer/swift/howto_installmultinode.html) is included the following commands.

Install common Swift software prereqs:

apt-get install python-software-properties
add-apt-repository ppa:swift-core/release<-----
apt-get update
apt-get install swift python-swiftclient openssh-server

Thierry Carrez (ttx) said : #4

Ubuntu 12.04 has Swift in its "main" archives (version 1.4.8-0ubuntu2.2) which was superseding the PPA version anyway. Could you tell us what your current swift version is ("dpkg -l swift") ? If the main version was used, you can just remove the PPA (sudo add-apt-repository -r ppa:swift-core/release).

Hi,

Yes.I have swift 1.4.8-0ubuntu2.2 version.
I can not install PPA repository, how can I remove the PPA?

Thierry Carrez (ttx) said : #6

If the PPA is not installed, you can just skip the add-apt-repository line in the instructions.

The add-apt-repository was meant to add a PPA which would contain the swift packages. Since Swift was included in the "main" repository for 12.04, there is no need to add a PPA to install Swift. So you can just ignore the error.

Hi,

Thanks for your answer. Could you please update this knowledge for a Multiple Server Swift Installation document(http://docs.openstack.org/developer/swift/howto_installmultinode.html)

Regards.

Can you help with this problem?

Provide an answer of your own, or ask Mehmet Hacısalihoğlu for more information if necessary.

To post a message you must log in.