OpenStack Object Storage (Swift)

Problem with Temp-auth

Asked by arghyadip on 2011-10-31

Hi I am new to OpenStack Object store.

I have so far installed the swift on multiple nodes. And after I have configured each of the Storage Nodes and Proxy Nodes I am trying the tempauth. While trying to create an account I am invoking the following command

curl -k -v -H 'X-Storage-User: system:root' -H 'X-Storage-Pass: testpass' https://$PROXY_LOCAL_NET_IP:8080/auth/v1.0

But I am getting the following error in the terminal

* About to connect() to 128.111.55.19 port 8080 (#0)
* Trying 128.111.55.19... connected
* Connected to 128.111.55.19 (128.111.55.19) port 8080 (#0)
* successfully set certificate verify locations:
* CAfile: none
  CApath: /etc/ssl/certs
* SSLv3, TLS handshake, Client hello (1):
* Unknown SSL protocol error in connection to 128.111.55.19:8080
* Closing connection #0
curl: (35) Unknown SSL protocol error in connection to 128.111.55.19:8080

The Proxy-server.conf file is as follows:

[DEFAULT]
cert_file = /etc/swift/cert.crt
key_file = /etc/swift/cert.key
bind_port = 8080
workers = 8
user = swift
log_name = swift
log_facility = LOG_LOCAL0
log_level = DEBUG

[pipeline:main]
pipeline = healthcheck cache tempauth proxy-server

[app:proxy-server]
use = egg:swift#proxy
allow_account_management = true
set log_name = proxy-server
set log_facility = LOG_LOCAL0
set log_level = DEBUG

[filter:tempauth]
use = egg:swift#tempauth
user_system_root = testpass .admin https://128.111.55.19:8080/v1/AUTH_system
set log_name = tempauth
set log_facility = LOG_LOCAL0
set log_level = DEBUG
[filter:healthcheck]
use = egg:swift#healthcheck

[filter:cache]
use = egg:swift#memcache
memcache_servers = 128.111.55.19:11211

The Debug Logs found in sys-log is as follows:

Oct 30 21:27:53 bobcats proxy-server UNCAUGHT EXCEPTION Traceback (most recent call last): File "/usr/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port=8080, **options) File "/usr/lib/pymodules/python2.6/swift/common/wsgi.py", line 172, in run_wsgi run_server() File "/usr/lib/pymodules/python2.6/swift/common/wsgi.py", line 137, in run_server wsgi.server(sock, app, NullLogger(), custom_pool=pool) File "/usr/lib/pymodules/python2.6/eventlet/wsgi.py", line 589, in server client_socket = sock.accept() File "/usr/lib/pymodules/python2.6/eventlet/green/ssl.py", line 301, in accept suppress_ragged_eofs=self.suppress_ragged_eofs) File "/usr/lib/pymodules/python2.6/eventlet/green/ssl.py", line 47, in __init__ super(GreenSSLSocket, self).__init__(sock.fd, *args, **kw) File "/usr/lib/python2.6/ssl.py", line 113, in __init__ cert_reqs, ssl_version, ca_certs) SSLError: [Errno 336265225] _ssl.c:337: error:140B0009:SSL routines:SSL_CTX_use_PrivateKey_file:PEM lib
Oct 30 21:27:53 bobcats proxy-server Removing dead child 16463
Oct 30 21:27:53 bobcats proxy-server Started child 16583

Please help me to get this fix.

Thanks and Regards,
Arghyadip

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Object Storage (swift) Edit question
Assignee:
No assignee Edit question
Solved by:
arghyadip
Solved:
2011-11-01
Last query:
2011-11-01
Last reply:
2011-10-31
Marcelo Martins (btorch) said : #1

Hi Arghyadip,

A couple of things I would recommend.

1) First, try getting the system working without SSL being enabled. Then you can try with SSL

2) Don't use "X-Storage-User" or "'X-Storage-Pass" anymore. Instead use "X-Auth-User" and "X-Auth-Key"

3) Lastly, I would suggest you use swauth for this multinode setup even if it is just a testing/staging environment. Tempauth is more for testing/development on a swift SAIO setup.

https://github.com/gholt/swauth

arghyadip (arghyadip) said : #2

The problem is solved..I was using wrong cert file.