Command line language

Asked by TheTwisted on 2009-02-17

I can't seem to change the language from Command Line.
For the command line, I used -l en, -l eng -l english.. the resulting downloads is still spanish, which i guess is the first subtitle found.
Any tips on this?

Question information

Language:
English Edit question
Status:
Solved
For:
SubDownloader Edit question
Assignee:
No assignee Edit question
Solved by:
Marco Ferreira
Solved:
2009-02-17
Last query:
2009-02-17
Last reply:
2009-02-17
Ivan Garcia (capiscuas) said : #1

It's already supported.

Have you tried the --cli option?

Best Regards.

TheTwisted (thetwisted) said : #2

yeah, but cant figure is out. Isn't there any documentation? because i cannot find it.

When I try "run --cli" in the windows binary version I get a run.exe.log file with "[>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>]100% Time: 00:00:00" in it

I also tried the source
E:\subdownloader-2.0.9.3\subdownloader>python run.py --cli
Traceback (most recent call last):
  File "run.py", line 35, in <module>
    import modules.configuration as conf
  File "E:\subdownloader-2.0.9.3\subdownloader\modules\configuration.py", line 2
2, in <module>
    import user
ImportError: No module named user

Best Marco Ferreira (mferreira) said : #3

Hi.

Try the -h option. That will give you a list of available options for the SD.

Cheers

Marco Ferreira (mferreira) said : #4

Oh, and there is always 'man subdownloader' if you installed the binary package.

TheTwisted (thetwisted) said : #5

Thanks Marco Ferreira, that solved my question.

TheTwisted (thetwisted) said : #6

thank you, i now got it to work!

kemikelx (yabayaba) said : #7

i can seem to change the language.
For the command line, I used -l en, -l eng -l english.. the resulting downloads is still spanish, which i guess is the first subtitle found.
Any tips on this?

Marco Ferreira (mferreira) said : #8

Hi.

Could you execute again but including the -d (debug) flag, and paste the output here?

cheers