Full-screen mode flicker (ATI Radeon 4650 on Windows 7 64 bit)

Asked by Nathan Eaton on 2010-02-01

I have an HP media PC (Intel Quadcore 6600 with 4GB of RAM) running Windows 7 Professional 64 bit.

My kids gave me a new graphics card for the media PC at Christmas, an ATI Radeon 4650 PCIE with 1GB RAM. So far, it's been a nice improvement over the original card - except when I run Stellarium. In windowed-mode, everything works fine but in full-screen mode (which includes Stellarium start-up) the screen flickers constantly. In addition, frames per second drops from 40-60 in windowed mode (even maximized) down to 7-10 in full-screen mode.

I found something somewhere (have lost track of where) that mentioned possible Stellarium problems with a graphics card that's been overclocked. When we were first testing the new card, my son had turned on the overclocking feature in the ATI control panel. I've since returned it to factory settings but that didn't elminate the flicker in Stellarium. The only other thing I've come up with to try is to uninstall the graphics card software and reinstall it. I haven't done that yet... wanted to first see whether there were other alternatives to explore.

Any suggestions?

I'm posting a request for help on the ATI support forum, too.

Thanks,
Nathan

Question information

Language:
English Edit question
Status:
Solved
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Solved by:
Nathan Eaton
Solved:
2010-02-17
Last query:
2010-02-17
Last reply:
2010-02-05
Jake (elocekaj) said : #1

Hey Nathan, i'm running Windows 7 64-bit as well (oddly enough, Q6600 processor and 4GB of RAM, though i have a Radeon 4850) i experienced the same problem. All I had to do was maneuver my mouse along the bottom row of buttons (not an easy task when you cant see your cursor) and managed to get "Full-Screen Mode" highlighted, once you click on that it should bring it into Windowed Mode and stop flickering. Hope this works for you as well

Nathan Eaton (neatonjr) said : #2

Thanks, Jake. I did figure out how to switch to windowed mode. While that is ok, I have a 46" LCD TV that Stellarium in full-screen with the lights out should look spectacular. I'd rather not have things like the task bar and window chrome showing, hence my interest in resolving the flicker issue permanently.

Clear skies,
Nathan

Zig (metabolism) said : #3

Same problem here, running Win 7 64-bit on a Core i5 750 with a Radeon HD 4650 card. Interesting that, after I get to windowed mode, I can increase the window to full-screen without a glitch.

JasonGissing (jasongiss) said : #4

Hi there. I'm not sure if you're still having this problem?
I was getting the same awful flickering, but right-clicking on the shortcut, going to properties/Compatibility and checking "Disable Desktop composition" fixed the issue for me.

I hope it does for you too!

Nathan Eaton (neatonjr) said : #5

Thanks, Jason... that did the trick. When I updated the properties to the shortcut to disable desktop composition, the first time Stellarium started it was in maximized window mode. Realizing I had previously updated the config.ini to set Full Screen Mode to false because of the flickering in fullscreen mode, I updated the config.ini to set that back to true. Now, when I start Stellarium it comes up in fullscreen mode with no flicker.

One thing I noticed is that it is putting Windows 7 into basic color scheme (i.e., no Aero features like transparent windows) but once I exit Stellarium it returns the color scheme to normal.

I'd suggest this option being added to the Stellarium FAQ for Windows (unless it is already there and I missed it).

Regards,
Nathan

Zig (metabolism) said : #6

The above worked for me, too.

Bill Zigrang

JasonGissing (jasongiss) said : #7

Great! Glad to hear it's worked for other people as well!

I've just found this software, and it does seem pretty amazing!

Cheers,
Jason

Jim (jfa8) said : #8

Just found this great software and as I am running Win7 Pro 64bit with a Radeon HD 5850 card I had the flickering problem as well.
Your suggested fix did the trick, thanks Jason.
There definitely should be a note somewhere alerting new users to this one.