ERROR: SpecialZoneArray( 8 )stars_8_2v0_0.cat error

Asked by Jason on 2010-01-18

hi star cat 8 wont work
this is the log

2010-01-17T20:26:00
C:\Program Files\Stellarium\stellarium.exe
Windows XP
Compiled with GCC 3.4.2
Qt runtime version: 4.5.0
Qt compilation version: 4.5.0
Addressing mode: 32-bit
Total memory: 2046 MB (unreliable)
Total virtual memory: 2047 MB (unreliable)
Physical memory in use: 24%
Processor speed: 2793 MHz
Processor name: Pentium(R) Dual-Core CPU E6300 @ 2.80GHz
Processor speed: 2793 MHz
Processor name: Pentium(R) Dual-Core CPU E6300 @ 2.80GHz
 -------------------------------------------------------
[ This is Stellarium 0.10.2 - http://www.stellarium.org ]
[ Copyright (C) 2000-2009 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "C:/Documents and Settings/me/Application Data/Stellarium/log.txt"
File search paths:
  0 . "C:/Documents and Settings/me/Application Data/Stellarium"
  1 . "."
Config file is: "C:/Documents and Settings/me/Application Data/Stellarium/config.ini"
Cache directory is: "C:\Documents and Settings\me\Local Settings\Application Data\stellarium\stellarium\cache"
Sky language is "en"
Application language is "en"
Loading Solar System data ...
Loaded 38 / 38 planet orbits
Loading star data ...
Loading "stars_0_0v0_1.cat": 0_0v0_1; 5013
Loading "stars_1_0v0_1.cat": 1_0v0_1; 21999
Loading "stars_2_0v0_1.cat": 2_0v0_1; 151416
Loading "stars_3_1v0_0.cat": 3_1v0_0; 434064
Loading "stars_4_1v0_0.cat": 4_1v0_0; 1725497
Loading "stars_5_2v0_0.cat": 5_2v0_0; 7669011
Loading "stars_6_2v0_0.cat": 6_2v0_0; 26615233
Loading "stars_7_2v0_0.cat": 7_2v0_0; 57826266
ERROR: SpecialZoneArray( 8 )::SpecialZoneArray: QFile( "C:/Documents and Settings/me/Application Data/Stellarium/stars/default/stars_8_2v0_0.cat" .map( 5242912 , 701538504 ) failed: "Not enough storage is available to process this command."
"Loading "stars_8_2v0_0.cat": 8_2v0_0; - initialization failed"
Finished loading star catalogue data, max_geodesic_level: 7
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 / 13226 NGC records
Loading NGC name data ...
Loaded 222 / 222 NGC name records successfully
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Loading star names from "./skycultures/western/star_names.fab"
Loaded 230 / 230 common star names
Loading star names from "./stars/default/name.fab"
Loaded 3215 / 4359 scientific star names
Creating GUI ...

Question information

Language:
English Edit question
Status:
Answered
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Last query:
2010-01-18
Last reply:
2010-01-18
Bogdan Marinov (daggerstab) said : #1

Someone else complained of the same thing before. It seems to be a memory problem on Windows. Have in mind that catalog 8 is 700 MB on the disk, and will be larger when loaded. :)

To remove the catalog, you have to find the stars.ini configuration file and remove the pair of lines that describes the catalog. They are something like:

[stars/stars_8_2v0_0]
path = stars_8_2v0_0.cat

I think that on Windows XP you will find the stars.ini file in Stellarium's directory in Program Files. Open the sub-directory called "stars" and then the one called "default".

If it's not there, try Stellarium's data directory. It should be something like C:\Documents and Settings\Your User Name\Application Data\Stellarium

Can you help with this problem?

Provide an answer of your own, or ask Jason for more information if necessary.

To post a message you must log in.