The configuration buttons are completely distorted when installed in ubuntu 9.1

Asked by ianyikos on 2009-11-29

When I run Stellarium in ubuntu 9.1, the configuration buttons, as well as the configuration menus, appear completely distorted, but the sky and the stars look perfectly fine. I've tried reinstalling it, but it hasn't made any difference. I downloaded all of the required packages to run Stellarium, so there must be a problem with how it was installed on my computer. I used the ubuntu software center to install it, which is how I installed it in the previous version of ubuntu without any problems. What is the correct way, as well as the required packages, to install and run Stellarium in ubuntu 9.1?

Question information

Language:
English Edit question
Status:
Answered
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-30
Last reply:
2010-01-18
Bogdan Marinov (daggerstab) said : #1

Do you have an Intel graphics card? There seems to be a problem with the drivers.

Can you confirm that you are seeing the same thing as described in this bug report?
https://bugs.launchpad.net/stellarium/+bug/426417
(There are screenshots attached in it.)

ianyikos (ianyikos) said : #2

Yeah that's definitely the same problem. I'm sorry, I just didn't see that post before today. But I don't really know how to fix the problem exactly. Do I have to build the program manually, or do I need to update my graphics driver or something? I've never tried building a program manually, since I'm new to using linux.

ianyikos (ianyikos) said : #3

And yes I do have an intel graphics card.

Bogdan Marinov (daggerstab) said : #4

Unfortunately, it seems that at the moment there's nothing that you can do. You can try to use a new driver version, if/when one is available.

You can also try to download the source from the repository and build the development version, although it is not clear if this will fix the problem. These days there are daily changes in the OpenGL code.

Building Stellarium from source is relatively easy on Ubuntu, as the installation of dependencies can be done easily. You'll have to do some work in the console, though.

Do you want to try it? There's a page with instructions in the Stellarium Wiki, but it's a bit outdated. If you need help, you can join the mailing list and ask for help:
https://launchpad.net/~stellarium-devel

David Fraser (davidf) said : #5

If you look at the bug linked above, you'll find instructions for using a program called driconf to turn off the texture tiling where the bug is - that is a workaround until the bug is fixed, but it's certainly much easier than compiling from source, which isn't even guaranteed to fix it... (quoting from the bug):

The "driconf" package can be installed with the Synaptic package manager or by opening a terminal and typing:

sudo apt-get install driconf

It will be added in the menus as System->Preferences->3D Acceleration.

You can disable texture tiling globally, or you can use the Application settings field to add a profile and disable texture tiling only for Stellarium. In the profile set the executable to stellarium (lower-case).

Here's a screenshot of the tool:
http://launchpadlibrarian.net/36861851/Screenshot-Direct%20Rendering%20Preferences-Tiling-Off.png

Can you help with this problem?

Provide an answer of your own, or ask ianyikos for more information if necessary.

To post a message you must log in.