Runtime Error after downloading star catalogue updates

Asked by jlaroccaiii on 2009-11-20

After downloading the star catalogue updates from the link in the "configuration" box the program advises you to restart to view all the stars. Upon restarting I receive the following messages: "Runtime Error!" and "The instruction at 0x69398659 referenced memroy at 0x000000cc. The memory could not be read." When I click OK the program terminates. I have uninstalled and reinstalled stellarium and tried the downloads again only to be confronted with the same problem.

Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Solved by:
Bogdan Marinov
Solved:
2009-11-29
Last query:
2009-11-29
Last reply:
2009-11-21
jlaroccaiii (jlaroccaiii) said : #2

I wish that worked. That seems to be for Windows 7 and I'm running XP. I can only run in compatibility mode for the older models of windows and I tried it...it wasn't pretty. I was unable to even load Stellarium. I couldn't uninstall it either...not completely. I couldn't reinstall it either as it kept locking up. I finally did a system restore to a point prior to screwing with it. I'm back up and running with no problems but also without the star catalogues.

Any other ideas?

WIN XP service pack 3
Dell Dimension 8400, x86 based PC
1 gig ram

Best Bogdan Marinov (daggerstab) said : #3

This happens when one of the catalogs has been corrupted or not downloaded completely. The configuration file that tells Stellarium how much catalogs are installed is modified before the downloading starts, not after it finishes (as it should be).

The path is something like
C:\Program Files\Stellarium\stars\default\stars.ini

Your problem could be solved by editing the stars.ini file and removing the lines for the additional catalogs (the first four are the ones installed with Stellarium).

You can try downloading the catalogs from one by one, restarting Stellarium after each one. If there is a problem after an automatic download, you can download the file manually from SourceForge:
http://sourceforge.net/projects/stellarium/files/Extra-data-files/
Just put it in that folder, you don't need to modify the stars.ini file, because it has already been modified. :)

jlaroccaiii (jlaroccaiii) said : #4

I kept it simple. I downloaded each update separately and restarted Stellarium between each update. It worked! Thanks for the help!