Stellarium won't launch in Windows 7

Asked by Curtis on 2009-11-14

I downloaded and installed Stellarium - successfully at first, however, after trying to install the additional libraries, the program refuses to launch. A Microsoft C++ Runtime Library Window pops up saying:

     "This application has requested the Runtime to terminate in an unusual way. Please contact the application's support team for assistance."

     I tried uninstalling and reinstalling w/o success. The launch window has the message: "Loading catalog stars_0_0v0_1 from the file stars_0_0v0_1.cat"

     Anyone have a good idea how to get this problem fixed?

Question information

Language:
English Edit question
Status:
Answered
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Last query:
2010-01-24
Last reply:
2010-01-26
Fabien Chéreau (xalioth) said : #1

Do you have a 64 bits computer? If yes, you may experience this bug: https://bugs.launchpad.net/stellarium/+bug/482722
If it's the case, please add your experience on the bug report.
Fabien

windu (willdevelop) said : #2

Greetings...I have an AMD 64 bit PC running Windows 7. I installed 0.10.2 yesterday and everything ran fine. Began to download star catalog updates but had to cancel. When I started Stellarium today, I got your same error. I uninstalled the program then deleted any reference to the config.ini. I reinstalled and got the same error. Finally right clicked on the Stellarium icon, selected properties, clicked on the compaibility tab, checked the box "Run this program in compatibility mode" and chose Windows XP (Service Pack 3). I also checked "Run this program as administrator". The program worked correctly after that. I hope this helps.

MikeA (mikea) said : #3

Running Windows 7Pro, Xenon Quad 64 bit, same problem with runtime error. Tried the run in compatibility mode and set full screen mode to False in the .ini file as a precaution and all is ok.

Thanks for the tip windu.

Curtis (cmyjbenham) said : #4

Thanks windu & Mike A for your replies. The program starts OK now, but hangs at some point. So far I have not been able to determine a probable cause. After a while, it just stops responding. Sometimes right away, other times after a while.

Richcom (10101richcom) said : #5

Hi Guys, the same error on Win 7,
Error from pop up window:
Microsoft Visual C++ Runtime Library
"This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information."
I start it in WinXP SP3 compatibility mode, as well as admin. This time start well but frozen during loading 77/84 pictures. And I still can't use it on that computer. Any clue ?

Curtis (cmyjbenham) said : #6

Hi,

     The answers provided to date have been helpful in that the program does
load and run for a while... at some point while exploring the cosmos
however, the screen freezes and becomes unresponsive. Sometimes this
happens right away, other times it may be 10 minutes or more.

Regards,

Curtis

On Sat, Jan 23, 2010 at 12:14 PM, Richcom <
<email address hidden>> wrote:

> Your question #90170 on Stellarium changed:
> https://answers.launchpad.net/stellarium/+question/90170
>
> Status: Open => Answered
>
> Richcom proposed the following answer:
> Hi Guys, the same error on Win 7,
> Error from pop up window:
> Microsoft Visual C++ Runtime Library
> "This application has requested the Runtime to terminate it in an unusual
> way.
> Please contact the application's support team for more information."
> I start it in WinXP SP3 compatibility mode, as well as admin. This time
> start well but frozen during loading 77/84 pictures. And I still can't use
> it on that computer. Any clue ?
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/stellarium/+question/90170/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/stellarium/+question/90170
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
1306 Canyon Ridge Lane
Plummer, ID 83851
cell phone: 208-582-1724
<email address hidden>

If you do not receive a response to an email within two days, please resend
the email. Thank you!

MikeA (mikea) said : #7

Hi, Curtis, I do not see the freeze problem.

When I had the loading problem I did the following:

1) Set full screen mode to False in the .ini file.

2) Set the compatibility mode for Vista SP1 rather than XP as I had been successfully
running Stellarium on that platform.

Not much help I am afraid but it fixed my load problems.

noelian (clay-simborios) said : #8

me i have updated my stars catalog in my stellarium i just downloaded it today and when i opened it i got the same error
 This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information."
i have win 7 running in 2.20Ghz core 2 duo 1GB of video card 3gb of RAM

Can you help with this problem?

Provide an answer of your own, or ask Curtis for more information if necessary.

To post a message you must log in.