Unable to receive DEC value from stellarium after slew command

Asked by khaja on 2018-12-22

Hi !
    I am trying to interface my telescope with stellarium in order to make my telescope a Goto model. I am using arduino to talk to stellarium based on LX200 protocol. So far I am getting :GR# and :GD# commands from stellarium and my code sends back RA and DEC values of telescope.

    But when I wanted to get RA DEC of target object from stellarium, I get only RA value, in this way; #:Q#:Sr 16:02:46#
  Anybody can help me find out why the stellarium is not sending DEC value?
  I want to avoid ASCOMM driver support as now.
  This is my first experience with telescope while I try to motorize it. So please help me.

Question information

Language:
English Edit question
Status:
Solved
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Solved by:
khaja
Solved:
2018-12-26
Last query:
2018-12-26
Last reply:
gzotti (georg-zotti) said : #1

I am afraid you will have to dive into the sources of the TelescopeControl plugin yourself, as most of the code has not been developed by the currently responding developers. There are some other projects around that had success with Arduinos or other little boards, please google for the respective forums.

khaja (minhajub) said : #2

Thanks Georg for responding.
 I solved my problem.
I only had to reply stellarium with an acknowledgement, then it would send another value. So DEC value was received after sendng ack to the stellarium.