problem display plugin satellite stellarium Linux Mint

Asked by PATRICK on 2017-05-08

Hi
I'm Patrick from France...I use Stellarium on my notebook with Linux Mint 1.7 It runs well but it looks like a little "bug" with the satellite plugin (I manage it just too see ISS) : so, when I click on the sat plugin button it displays all satellites with all orbits in accelerated !! it's messy :o) I didn't found why. Of course TLE are updated...

Does anyone have a solution for this problem ?
Thank a lot
Pat

Question information

Language:
English Edit question
Status:
Open
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Last query:
2017-05-17
Last reply:
2017-05-17
gzotti (georg-zotti) said : #1

There are many satellites in quite fast orbit, and many geostationary. Really too fast motion may indicate date mismatch. Do you have the correct system date? (May 2017!?)

PATRICK (arnaud-p-olivier) said : #2

...thanks Georg but no date mismatch in Stellarium and computer...both are update on 8th May 2017 :o)

PATRICK (arnaud-p-olivier) said : #3

...same problem on real time & with advanced or backward clock in Stellarium. Please note I use another Stellarium release with another computer & OS Windows : no problem...

Alexander Wolf (alexwolf) said : #4

How much fast 'is fast' for you? Could you make a 2 screenshots with 10 seconds in difference and with wide FOV?

P.S. Please use http://imgur.com service for screenshots, because Answers tool doesn't support attachments.

PATRICK (arnaud-p-olivier) said : #5

https://imgur.com/a/wdXXr
2 screenshot in few seconds...enable to make in 10s :o) too faster !

it looks like Stellarium display all TLE in same time accellerated To have an idea : imagine a sat not in real time but with time X100

what do you think about my "christmas tree" ? :o)

Alexander Wolf (alexwolf) said : #6

Could you show log from Stellarium?

PATRICK (arnaud-p-olivier) said : #7

2017-05-08T20:31:46
Linux version 3.13.0-24-generic (buildd@roseapple) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014
Compiled using GCC 4.8.2
Qt runtime version: 4.8.6
Qt compilation version: 4.8.4
Addressing mode: 32-bit
MemTotal: 2053852 kB
MemFree: 271592 kB
SwapTotal: 16794620 kB
model name : Intel(R) Atom(TM) CPU N450 @ 1.66GHz
cpu MHz : 1667.000
model name : Intel(R) Atom(TM) CPU N450 @ 1.66GHz
cpu MHz : 1667.000
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller (prog-if 00 [VGA controller])
Kernel driver in use: i915
stellarium
 -------------------------------------------------------
[ This is Stellarium 0.12.4 - http://www.stellarium.org ]
[ Copyright (C) 2000-2013 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "/home/patrick/.stellarium/log.txt"
File search paths:
  0 . "/home/patrick/.stellarium"
  1 . "/usr/share/stellarium"
Attempting to use an existing older config file.
Config file is: "/home/patrick/.stellarium/config.ini"
Going to initialize the OpenGL 2 renderer
OpenGL supported version: "1.4 Mesa 10.1.0"
Qt GL paint engine is: "OpenGL"
StelQGL2Renderer::init : Failed because Qt paint engine is not OpenGL2
If paint engine is OpenGL3 or higher, this code needs to be updated
Failed to initialize the OpenGL 2 renderer, falling back to the OpenGL 1 renderer
OpenGL supported version: "1.4 Mesa 10.1.0"
Qt GL paint engine is: "OpenGL"
GL vendor is "Intel Open Source Technology Center"
GL renderer is "Mesa DRI Intel(R) IGD x86/MMX/SSE2"
Cache directory is: "/home/patrick/.cache/stellarium/stellarium"
Sky language is "fr_FR"
Application language is "fr_FR"
Loading Solar System data ...
Loaded 75 / 75 planet orbits from "/home/patrick/.stellarium/data/ssystem.ini"
Loading star data ...
"Loading "/usr/share/stellarium/stars/default/stars_0_0v0_3.cat": 0_0v0_2; 4963"
"Loading "/usr/share/stellarium/stars/default/stars_1_0v0_3.cat": 1_0v0_2; 21598"
"Loading "/usr/share/stellarium/stars/default/stars_2_0v0_3.cat": 2_0v0_2; 150090"
"Loading "/usr/share/stellarium/stars/default/stars_3_1v0_2.cat": 3_1v0_1; 423540"
Finished loading star catalogue data, max_geodesic_level: 3
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 412 / 412 NGC name records successfully
Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
Loaded 236 / 236 common star names
Loading star names from "/usr/share/stellarium/stars/default/name.fab"
Loaded 4359 / 4359 scientific star names
Loading variable stars from "/usr/share/stellarium/stars/default/gcvs_hip_part.dat"
Loaded 6886 / 6886 variable stars
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Not using any viewport effect
Creating GUI ...
Loading shortcuts...
Can't find plugin with id "RendererStatistics"
Can't find plugin with id "RendererStatistics"
Loaded plugin "CompassMarks" .
CompassMarks plugin - press control-C to toggle compass marks
Loaded plugin "Exoplanets" .
Exoplanets::getJsonFileFormatVersion() version of format from file: 1
Exoplanets::init using file: "/home/patrick/.stellarium/modules/Exoplanets/exoplanets.json"
Loaded plugin "Novae" .
Novae::getJsonFileVersion() version from file: 1
Novae::init using file: "/home/patrick/.stellarium/modules/Novae/novae.json"
Loaded plugin "Observability" .
init called for Observability
Loaded plugin "Oculars" .
Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at: "/home/patrick/.stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version 2
Loaded plugin "Satellites" .
Satellites: loading catalog file: "/home/patrick/.stellarium/modules/Satellites/satellites.json"
Satellite has invalid orbit: "THOR AGENA D R/B" "00733"
Satellite has invalid orbit: "OAO 2" "03597"
Satellite has invalid orbit: "ISIS 1" "03669"
Satellite has invalid orbit: "SERT 2" "04327"
Satellite has invalid orbit: "NOAA 1" "04793"
Satellite has invalid orbit: "ASTEX 1" "05560"
Satellite has invalid orbit: "GOES 5" "12472"
Satellite has invalid orbit: "NOAA 7" "12553"
Satellite has invalid orbit: "METEOR PRIRODA" "12585"
Satellite has invalid orbit: "SL-3 R/B" "12904"
Satellite has invalid orbit: "SL-3 R/B" "13068"
Satellite has invalid orbit: "SL-3 R/B" "13154"
Satellite has invalid orbit: "SL-3 R/B" "13403"
Satellite has invalid orbit: "SL-3 R/B" "13819"
Satellite has invalid orbit: "NOAA 8" "13923"
Satellite has invalid orbit: "COSMOS 1500" "14372"
Satellite has invalid orbit: "UOSAT 2 (UO-11)" "14781"
Satellite has invalid orbit: "COSMOS 1544" "14819"
Satellite has invalid orbit: "ERBS" "15354"
Satellite has invalid orbit: "SL-8 R/B" "15483"
Satellite has invalid orbit: "COSMOS 1626" "15494"
Satellite has invalid orbit: "SL-14 R/B" "16792"
Satellite has invalid orbit: "SL-14 R/B" "18749"
Satellite has invalid orbit: "COSMOS 1933" "18958"
Satellite has invalid orbit: "SL-16 R/B" "19650"
Satellite has invalid orbit: "SL-14 R/B" "20262"
Satellite has invalid orbit: "DELTA 1 R/B" "20323"
Satellite has invalid orbit: "LUSAT (LO-19)" "20442"
Satellite has invalid orbit: "COSMOS 2058" "20465"
Satellite has invalid orbit: "SL-14 R/B" "20466"
Satellite has invalid orbit: "SL-14 R/B" "20511"
Satellite has invalid orbit: "COSMOS 2084" "20663"
Satellite has invalid orbit: "SL-6 R/B(2)" "20666"
Satellite has invalid orbit: "SL-8 R/B" "20775"
Satellite has invalid orbit: "SL-8 R/B" "21088"
Satellite has invalid orbit: "NOAA 12" "21263"
Satellite has invalid orbit: "COSMOS 2151" "21422"
Satellite has invalid orbit: "SL-14 R/B" "21423"
Satellite has invalid orbit: "ERS-1" "21574"
Satellite has invalid orbit: "ARIANE 40 R/B" "21610"
Satellite has invalid orbit: "INTERCOSMOS 25" "21819"
Satellite has invalid orbit: "SL-14 R/B" "21820"
Satellite has invalid orbit: "SL-8 R/B" "21876"
Satellite has invalid orbit: "COSMOS 2228" "22286"
Satellite has invalid orbit: "INTELSAT 701 (IS-701)" "22871"
Satellite has invalid orbit: "GOES 8" "23051"
Satellite has invalid orbit: "SL-16 R/B" "23088"
Satellite has invalid orbit: "AMC-2 (GE-2)" "24713"
Satellite has invalid orbit: "IRIDIUM 911" "24842"
Satellite has invalid orbit: "ORBVIEW 2 (SEASTAR)" "24883"
Satellite has invalid orbit: "ABS-3" "24901"
Satellite has invalid orbit: "IRIDIUM 46" "24905"
Satellite has invalid orbit: "DUMMY MASS 1" "24925"
Satellite has invalid orbit: "IRIDIUM 31" "24950"
Satellite has invalid orbit: "IRIDIUM 42" "25077"
Satellite has invalid orbit: "IRIDIUM 24" "25105"
Satellite has invalid orbit: "INMARSAT 3-F5" "25153"
Satellite has invalid orbit: "IRIDIUM 52" "25169"
Satellite has invalid orbit: "IRIDIUM 61" "25263"
Satellite has invalid orbit: "IRIDIUM 58" "25274"
Satellite has invalid orbit: "IRIDIUM 60" "25276"
Satellite has invalid orbit: "IRIDIUM 65" "25288"
Satellite has invalid orbit: "IRIDIUM 66" "25289"
Satellite has invalid orbit: "IRIDIUM 67" "25290"
Satellite has invalid orbit: "IRIDIUM 68" "25291"
Satellite has invalid orbit: "IRIDIUM 70" "25342"
Satellite has invalid orbit: "IRIDIUM 72" "25343"
Satellite has invalid orbit: "IRIDIUM 73" "25344"
Satellite has invalid orbit: "SL-16 R/B" "25400"
Satellite has invalid orbit: "ASTRA 2A" "25462"
Satellite has invalid orbit: "IRIDIUM 82" "25467"
Satellite has invalid orbit: "IRIDIUM 81" "25468"
Satellite has invalid orbit: "JCSAT-4A" "25630"
Satellite has invalid orbit: "ASIASAT 3S" "25657"
Satellite has invalid orbit: "SL-8 R/B" "25723"
Satellite has invalid orbit: "HISPASAT 1C" "26071"
Satellite has invalid orbit: "EUTELSAT 80A" "26369"
Satellite has invalid orbit: "TDRS 8" "26388"
Satellite has invalid orbit: "ECHOSTAR 6" "26402"
Satellite has invalid orbit: "INTELSAT 9 (IS-9)" "26451"
Satellite has invalid orbit: "NILESAT 102" "26470"
Satellite has invalid orbit: "ASTRA 2B" "26494"
Satellite has invalid orbit: "NSS-7" "27414"
Satellite has invalid orbit: "DIRECTV 5 (TEMPO 1)" "27426"
Loaded plugin "SolarSystemEditor" .
Using the ssystem.ini file that already exists in the user directory...
Loaded plugin "TimeZoneConfiguration" .

a problem with sat orbits ???

Alexander Wolf (alexwolf) said : #8

Yeah! Please run updating TLE manually and see details in log.

PATRICK (arnaud-p-olivier) said : #9

Hi Alex
unfortunatly, same problem with updating manualy TLE as I do usually ;o( So, I deleted manually all sat list & just downloaded ISS and Swiss cube TLE + recording with button in menu. Then I run again the plugin = no orbits no sat on screen...a bit better but I'm not sure to see ISS in France today. To check it, I remove the landscape and surprise : no ISS nowhere. Of course it's impossible... Here is two screenshot : http://imgur.com/a/9Q4Dd ; http://imgur.com/a/qwor6

then, I downloaded few others satellite in the list (random) : GOES16 and 2017-023A. I don't see GOES 16 is probably "wrong" ; 2017-023A display itself correctly on screen (left on the next screenshot) but no orbits and it goes very fast in real time. (stellarium is paused ) http://imgur.com/a/UbN0b

Now : here the screenshot with only 4 sat in list : http://imgur.com/a/XNcel (Trajectories probably across the twilight zone:o)))

finally, I reboot Stellaruim, update TLE dor those 4sat manually and just ask for display only ISS : here's the result in real time :http://imgur.com/a/B1uUP

Mr Spock would have said "it's logical captain" ... I do not understand anything:o)
to followed...
Thanks, Pat

PATRICK (arnaud-p-olivier) said : #10

here's the last log:

2017-05-09T18:44:22
Linux version 3.13.0-24-generic (buildd@roseapple) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014
Compiled using GCC 4.8.2
Qt runtime version: 4.8.6
Qt compilation version: 4.8.4
Addressing mode: 32-bit
MemTotal: 2053852 kB
MemFree: 320760 kB
SwapTotal: 16794620 kB
model name : Intel(R) Atom(TM) CPU N450 @ 1.66GHz
cpu MHz : 1667.000
model name : Intel(R) Atom(TM) CPU N450 @ 1.66GHz
cpu MHz : 1667.000
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller (prog-if 00 [VGA controller])
Kernel driver in use: i915
stellarium
 -------------------------------------------------------
[ This is Stellarium 0.12.4 - http://www.stellarium.org ]
[ Copyright (C) 2000-2013 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "/home/patrick/.stellarium/log.txt"
File search paths:
  0 . "/home/patrick/.stellarium"
  1 . "/usr/share/stellarium"
Attempting to use an existing older config file.
Config file is: "/home/patrick/.stellarium/config.ini"
Going to initialize the OpenGL 2 renderer
OpenGL supported version: "1.4 Mesa 10.1.0"
Qt GL paint engine is: "OpenGL"
StelQGL2Renderer::init : Failed because Qt paint engine is not OpenGL2
If paint engine is OpenGL3 or higher, this code needs to be updated
Failed to initialize the OpenGL 2 renderer, falling back to the OpenGL 1 renderer
OpenGL supported version: "1.4 Mesa 10.1.0"
Qt GL paint engine is: "OpenGL"
GL vendor is "Intel Open Source Technology Center"
GL renderer is "Mesa DRI Intel(R) IGD x86/MMX/SSE2"
Cache directory is: "/home/patrick/.cache/stellarium/stellarium"
Sky language is "fr_FR"
Application language is "fr_FR"
Loading Solar System data ...
Loaded 75 / 75 planet orbits from "/home/patrick/.stellarium/data/ssystem.ini"
Loading star data ...
"Loading "/usr/share/stellarium/stars/default/stars_0_0v0_3.cat": 0_0v0_2; 4963"
"Loading "/usr/share/stellarium/stars/default/stars_1_0v0_3.cat": 1_0v0_2; 21598"
"Loading "/usr/share/stellarium/stars/default/stars_2_0v0_3.cat": 2_0v0_2; 150090"
"Loading "/usr/share/stellarium/stars/default/stars_3_1v0_2.cat": 3_1v0_1; 423540"
Finished loading star catalogue data, max_geodesic_level: 3
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 412 / 412 NGC name records successfully
Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
Loaded 236 / 236 common star names
Loading star names from "/usr/share/stellarium/stars/default/name.fab"
Loaded 4359 / 4359 scientific star names
Loading variable stars from "/usr/share/stellarium/stars/default/gcvs_hip_part.dat"
Loaded 6886 / 6886 variable stars
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Not using any viewport effect
Creating GUI ...
Loading shortcuts...
Can't find plugin with id "RendererStatistics"
Can't find plugin with id "RendererStatistics"
Loaded plugin "CompassMarks" .
CompassMarks plugin - press control-C to toggle compass marks
Loaded plugin "Exoplanets" .
Exoplanets::getJsonFileFormatVersion() version of format from file: 1
Exoplanets::init using file: "/home/patrick/.stellarium/modules/Exoplanets/exoplanets.json"
Loaded plugin "Novae" .
Novae::getJsonFileVersion() version from file: 1
Novae::init using file: "/home/patrick/.stellarium/modules/Novae/novae.json"
Loaded plugin "Observability" .
init called for Observability
Loaded plugin "Oculars" .
Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at: "/home/patrick/.stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version 2

Loaded plugin "Satellites" .
Satellites: loading catalog file: "/home/patrick/.stellarium/modules/Satellites/satellites.json"
Satellite has invalid orbit: "SWISSCUBE" "35932"
Satellite has invalid orbit: "2017-023A" "42691"
Satellite has invalid orbit: "2017-024A" "42695"
Satellite has invalid orbit: "2017-024B" "42696"
###########################
note : impossible ! & where is ISS ????
###########################
Loaded plugin "SolarSystemEditor" .
Using the ssystem.ini file that already exists in the user directory...
Loaded plugin "TimeZoneConfiguration" .
Unloaded plugin "TimeZoneConfiguration" .
Unloaded plugin "SolarSystemEditor" .
Unloaded plugin "Satellites" .
Unloaded plugin "Oculars" .
Unloaded plugin "Observability" .
Unloaded plugin "Novae" .
Unloaded plugin "Exoplanets" .
Unloaded plugin "CompassMarks" .
Downloaded 0 files (0 kbytes) in a session of 54.294 sec (average of 0 kB/s + 0 files from cache (0 kB)).

PATRICK (arnaud-p-olivier) said : #11

last idea : I tried to change source of data (celestrack NORAD) : it update correctly sat list in the plugin but show few sat on screen, without orbits and in accelerated...

Alexander Wolf (alexwolf) said : #12

Could you open terminal and run: export LC_NUMERIC=C stellarium

PATRICK (arnaud-p-olivier) said : #13

hi Alex
Better....here's what's the command line returm, below. (not sure100%...nothing append if i write "export"). After the terminal display those data, Stellarium automatically run itself and...satellites correctly display with speed & trajectories BUT if I lauched Stellarium normally from my desktop, it's the m...
Is it a Format for displaying numbers ?what could I do ?
nice day, Pat
_________
patrick@Notebookpat ~ $ LC_NUMERIC=C stellarium
Using default graphics system specified at build time: raster
 -------------------------------------------------------
[ This is Stellarium 0.12.4 - http://www.stellarium.org ]
[ Copyright (C) 2000-2013 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "/home/patrick/.stellarium/log.txt"
File search paths:
  0 . "/home/patrick/.stellarium"
  1 . "/usr/share/stellarium"
Attempting to use an existing older config file.
Config file is: "/home/patrick/.stellarium/config.ini"
Going to initialize the OpenGL 2 renderer
OpenGL supported version: "1.4 Mesa 10.1.0"
Qt GL paint engine is: "OpenGL"
StelQGL2Renderer::init : Failed because Qt paint engine is not OpenGL2
If paint engine is OpenGL3 or higher, this code needs to be updated
Failed to initialize the OpenGL 2 renderer, falling back to the OpenGL 1 renderer
OpenGL supported version: "1.4 Mesa 10.1.0"
Qt GL paint engine is: "OpenGL"
GL vendor is "Intel Open Source Technology Center"
GL renderer is "Mesa DRI Intel(R) IGD x86/MMX/SSE2"
Cache directory is: "/home/patrick/.cache/stellarium/stellarium"
Sky language is "fr_FR"
Application language is "fr_FR"
Loading Solar System data ...
Loaded 75 / 75 planet orbits from "/home/patrick/.stellarium/data/ssystem.ini"
Loading star data ...
"Loading "/usr/share/stellarium/stars/default/stars_0_0v0_3.cat": 0_0v0_2; 4963"
"Loading "/usr/share/stellarium/stars/default/stars_1_0v0_3.cat": 1_0v0_2; 21598"
"Loading "/usr/share/stellarium/stars/default/stars_2_0v0_3.cat": 2_0v0_2; 150090"
"Loading "/usr/share/stellarium/stars/default/stars_3_1v0_2.cat": 3_1v0_1; 423540"
Finished loading star catalogue data, max_geodesic_level: 3
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 412 / 412 NGC name records successfully
Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
Loaded 236 / 236 common star names
Loading star names from "/usr/share/stellarium/stars/default/name.fab"
Loaded 4359 / 4359 scientific star names
Loading variable stars from "/usr/share/stellarium/stars/default/gcvs_hip_part.dat"
Loaded 6886 / 6886 variable stars
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Not using any viewport effect
Creating GUI ...
Loading shortcuts...
Can't find plugin with id "RendererStatistics"
Can't find plugin with id "RendererStatistics"
Loaded plugin "CompassMarks" .
CompassMarks plugin - press control-C to toggle compass marks
Loaded plugin "Exoplanets" .
Exoplanets::getJsonFileFormatVersion() version of format from file: 1
Exoplanets::init using file: "/home/patrick/.stellarium/modules/Exoplanets/exoplanets.json"
Loaded plugin "Novae" .
Novae::getJsonFileVersion() version from file: 1
Novae::init using file: "/home/patrick/.stellarium/modules/Novae/novae.json"
Loaded plugin "Observability" .
init called for Observability
Loaded plugin "Oculars" .
Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at: "/home/patrick/.stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version 2
Loaded plugin "Satellites" .
Satellites: loading catalog file: "/home/patrick/.stellarium/modules/Satellites/satellites.json"
Satellite has invalid orbit: "SL-14 R/B" "26874"
Satellite has invalid orbit: "CZ-7 DEB" "42686"
Satellite has invalid orbit: "CZ-7 DEB" "42687"
Satellite has invalid orbit: "CZ-7 DEB" "42688"
Loaded plugin "SolarSystemEditor" .
Using the ssystem.ini file that already exists in the user directory...
Loaded plugin "TimeZoneConfiguration" .

Alexander Wolf (alexwolf) said : #14

Could you run in terminal echo $LC_NUMERIC and show result here?

PATRICK (arnaud-p-olivier) said : #15

hi Alex...unfortunately, nothing happened if I try this command line...

Alexander Wolf (alexwolf) said : #16

Could you run in terminal:
echo "LC_NUMERIC=C" >> ~/.profile
and make logout/login and check it again?

PATRICK (arnaud-p-olivier) said : #17

nothing: if I write exactly your command line, the terminal answer "unable to find LC_Numeric...(1st line below)
if I deleted >> it return "none files for this file-type (2nd line) http://imgur.com/a/Kfvfo
I tried with or without spaces (blank)...nothing. In stellarium nothing changed too even with a logout/in. Satellites are displays but in accelerated. I don't know the command line on linux so i don't understand what i do and I can't help you :o(

PATRICK (arnaud-p-olivier) said : #18

humm...i ask me if it could be a problem with partitions ? indeed, I got a problem with grub if I shutdow the laptop ...it boots in grub rescue...each time I need to rewrite the set prefix on HD0....I try to fix it...

Alexander Wolf (alexwolf) said : #19

OK, let me re-phrase: please add LC_NUMERIC=C at the end of ~/.profile file and logout/login after editing.

PATRICK (arnaud-p-olivier) said : #20

"permission not allowed" with this command line...what could I do ?

Alexander Wolf (alexwolf) said : #21

Could you open file /home/patrick/.profile and add string "LC_NUMERIC=C" (without quotes!) at the end of this file?

PATRICK (arnaud-p-olivier) said : #22

command line LC_NUMERIC=C added in .profile
The plugin satellites runs well only if I launch it from the terminal & with the command line "LC_numeric=c stellarium but if I launch Stellarium from the menu, satellites goes in accelerated with random trajectories as in the beginning. TLE correctly updated. Here's a copy from my terminal :

patrick@Notebookpat ~ $ echo $LC_NUMERIC
C
patrick@Notebookpat ~ $ LC_NUMERIC=C stellarium
Using default graphics system specified at build time: raster
 -------------------------------------------------------
[ This is Stellarium 0.12.4 - http://www.stellarium.org ]
[ Copyright (C) 2000-2013 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "/home/patrick/.stellarium/log.txt"
File search paths:
  0 . "/home/patrick/.stellarium"
  1 . "/usr/share/stellarium"
Attempting to use an existing older config file.
Config file is: "/home/patrick/.stellarium/config.ini"
Going to initialize the OpenGL 2 renderer
OpenGL supported version: "1.4 Mesa 10.1.0"
Qt GL paint engine is: "OpenGL"
StelQGL2Renderer::init : Failed because Qt paint engine is not OpenGL2
If paint engine is OpenGL3 or higher, this code needs to be updated
Failed to initialize the OpenGL 2 renderer, falling back to the OpenGL 1 renderer
OpenGL supported version: "1.4 Mesa 10.1.0"
Qt GL paint engine is: "OpenGL"
GL vendor is "Intel Open Source Technology Center"
GL renderer is "Mesa DRI Intel(R) IGD x86/MMX/SSE2"
Cache directory is: "/home/patrick/.cache/stellarium/stellarium"
Sky language is "fr_FR"
Application language is "fr_FR"
Loading Solar System data ...
Loaded 75 / 75 planet orbits from "/home/patrick/.stellarium/data/ssystem.ini"
Loading star data ...
"Loading "/usr/share/stellarium/stars/default/stars_0_0v0_3.cat": 0_0v0_2; 4963"
"Loading "/usr/share/stellarium/stars/default/stars_1_0v0_3.cat": 1_0v0_2; 21598"
"Loading "/usr/share/stellarium/stars/default/stars_2_0v0_3.cat": 2_0v0_2; 150090"
"Loading "/usr/share/stellarium/stars/default/stars_3_1v0_2.cat": 3_1v0_1; 423540"
Finished loading star catalogue data, max_geodesic_level: 3
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 412 / 412 NGC name records successfully
Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
Loaded 236 / 236 common star names
Loading star names from "/usr/share/stellarium/stars/default/name.fab"
Loaded 4359 / 4359 scientific star names
Loading variable stars from "/usr/share/stellarium/stars/default/gcvs_hip_part.dat"
Loaded 6886 / 6886 variable stars
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Not using any viewport effect
Creating GUI ...
Loading shortcuts...
Can't find plugin with id "RendererStatistics"
Can't find plugin with id "RendererStatistics"
Loaded plugin "CompassMarks" .
CompassMarks plugin - press control-C to toggle compass marks
Loaded plugin "Exoplanets" .
Exoplanets::getJsonFileFormatVersion() version of format from file: 1
Exoplanets::init using file: "/home/patrick/.stellarium/modules/Exoplanets/exoplanets.json"
Loaded plugin "Novae" .
Novae::getJsonFileVersion() version from file: 1
Novae::init using file: "/home/patrick/.stellarium/modules/Novae/novae.json"
Loaded plugin "Observability" .
init called for Observability
Loaded plugin "Oculars" .
Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at: "/home/patrick/.stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version 2
Loaded plugin "Satellites" .
Satellites: loading catalog file: "/home/patrick/.stellarium/modules/Satellites/satellites.json"
Satellite has invalid orbit: "SL-14 R/B" "26874"
Loaded plugin "SolarSystemEditor" .
Using the ssystem.ini file that already exists in the user directory...
Loaded plugin "TimeZoneConfiguration" .
Unloaded plugin "TimeZoneConfiguration" .
Unloaded plugin "SolarSystemEditor" .
Unloaded plugin "Satellites" .
Unloaded plugin "Oculars" .
Unloaded plugin "Observability" .
Unloaded plugin "Novae" .
Unloaded plugin "Exoplanets" .
Unloaded plugin "CompassMarks" .
Downloaded 0 files (0 kbytes) in a session of 33.175 sec (average of 0 kB/s + 0 files from cache (0 kB)).

Can you help with this problem?

Provide an answer of your own, or ask PATRICK for more information if necessary.

To post a message you must log in.