Moon disappears during total solar eclipse on 8-12-17

Asked by Chuck Boren III on 2016-09-14

I wanted to make a movie (using Stellarium 0.15.0 and Windows 8.1) of the total solar eclipse on Aug 21,2017 however, the moon disappears just as the solar eclipse begins and reappears after the solar eclipse ends. would anyone know of the the proper settings to keep this from happening.

Question information

Language:
English Edit question
Status:
Solved
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Solved by:
Chuck Boren III
Solved:
2016-09-18
Last query:
2016-09-18
Last reply:
2016-09-18
gzotti (georg-zotti) said : #1

This may depend on your hardware or drivers.
gzotti suggests this article as an answer to your question:
FAQ #2707: “Reporting a crash or serious problem”.

Chuck Boren III (chuckboren3) said : #2

FAQ #2707 DOES NOT SOLVE THE PROBLEM. I'm not experiencing a crash while using Stellarium. It has to do with displaying the moon during the August 21 2017 Solar eclipse. The Moon disappears as the eclipse begins and reappears after it ends. It has nothing to do with a crash.

gzotti (georg-zotti) said : #3

It has to do with a serious problem.

Chuck Boren III (chuckboren3) said : #4

My problem is that if you lock on to the sun, the moon will disappear just as the solar eclipse of August 21 2017 begins and reappears the moment the eclipse ends. Stellarium 0.15.0 continues to run properly. I'm using windows 8.1 on a PC.

Alexander Wolf (alexwolf) said : #5

Please try remove all Stellarium's data from User Directory and run Stellarium again.

Chuck Boren III (chuckboren3) said : #6

Alexander Wolf
Are you referring to the Stellarium ini file?

Alexander Wolf (alexwolf) said : #7

Yes, in general.

Chuck Boren III (chuckboren3) said : #8

Alexander Wolf
I deleted the info in the ini file and it didn't cure the problem I'm having in creating the movie.

Alexander Wolf (alexwolf) said : #9

Please show first 50 lines from log.txt file.

Chuck Boren III (chuckboren3) said : #10

Alexander Wolf
I've searched the Stellarium folder for a log.txt file and found none. Is there a different place I should be look in for the log.txt file that Stellarium uses?

Alexander Wolf (alexwolf) said : #11

Perfect! What exactly you are deleted before in that case?

Chuck Boren III (chuckboren3) said : #12

Alexander Wolf
You asked me to delete the contents of the ssystem.ini file that stellarium uses for information on the objects that orbit around the sun.

Alexander Wolf (alexwolf) said : #13

Yes, and if you found and deleted ssystem.ini file in User Directory then you already found log.txt file. And same question again: What exactly you are deleted before?

Chuck Boren III (chuckboren3) said : #14

Alexander Wolf
Other than running Stellarium with the contents in the ini file intact then again with the contents deleted (as an empty file), I didn't delete anything. I still have the same problem. I made a .avi file of what happens whit I try to make the movie of the August 21 2017 total solar eclipse and could email to you if you want to watch to see what happens.

Alexander Wolf (alexwolf) said : #15

OMG, it's incredible! If you do nothing, then nothing changes. Please DEINSTALL Stellarium, DELETE all Stellarium's files and directories (in Program Files AND in User Directory) and INSTALL Stellarium again.

Alexander Wolf (alexwolf) said : #16

Related to FAQ: generic recommendation: check drivers. If it did not help, then fill bug report or question and ATTACH or SHOW log file for getting objective technical info.

How log.txt can be found:
1) Start -> Programs -> Stellarium -> Latest run log
2) Press F1 within Stellarium and open tab "Log"
3) Use our wiki for getting detailed info for location of log.txt
4) Use Stellarium User Guide (already installed on your PC and Start -> Programs -> Stellarium -> Stellarium User Guide) for getting detailed info for location of log.txt
5) Use functions of operating system for finding file "log.txt"

This is very sad, that users cannot make an elementary operations. :(

Chuck Boren III (chuckboren3) said : #17

the following is the first 50 lines of text in the log.txt file.
2016-09-17T22:06:19
Windows 8.1
Compiled using MSVC++ 12.0 (Visual Studio 2013)
Qt runtime version: 5.6.1
Qt compilation version: 5.6.1
Addressing mode: 64-bit
Total physical memory: 3981 MB
Available physical memory: 2366 MB
Physical memory in use: 40%
Processor speed: 1796 MHz
Processor name: Intel(R) Core(TM) i3-3217U CPU @ 1.80GHz
Processor speed: 1796 MHz
Processor name: Intel(R) Core(TM) i3-3217U CPU @ 1.80GHz
Processor speed: 1796 MHz
Processor name: Intel(R) Core(TM) i3-3217U CPU @ 1.80GHz
Processor speed: 1796 MHz
Processor name: Intel(R) Core(TM) i3-3217U CPU @ 1.80GHz
C:\Program Files\Stellarium\stellarium.exe
 -------------------------------------------------------
[ This is Stellarium 0.15.0 - http://www.stellarium.org ]
[ Copyright (C) 2000-2016 Fabien Chereau et al. ]
 -------------------------------------------------------
Writing log file to: "C:\\Users\\Chuck Boren\\AppData\\Roaming\\Stellarium\\log.txt"
File search paths:
  0 . "C:\\Users\\Chuck Boren\\AppData\\Roaming\\Stellarium"
  1 . "."
Config file is: "C:\\Users\\Chuck Boren\\AppData\\Roaming\\Stellarium\\config.ini"
Detected: OpenGL "4.0"
Driver version string: "4.0.0 - Build 10.18.10.3308"
GL vendor is "Intel"
GL renderer is "Intel(R) HD Graphics 4000"
GL Shading Language version is "4.00 - Build 10.18.10.3308"
GLSL Version Number detected: 4
GLSL version is fine, we should not see a graphics problem.
Cache directory is: "C:\\Users\\Chuck Boren\\AppData\\Local\\stellarium\\stellarium\\cache"
Sky language is "en_US"
Application language is "en_US"
Loading Solar System data ...
Loading star data ...
"Loading \".\\stars\\default\\stars_0_0v0_6.cat\": 0_0v0_6; 4979"
"Loading \".\\stars\\default\\stars_1_0v0_6.cat\": 1_0v0_6; 21800"
"Loading \".\\stars\\default\\stars_2_0v0_6.cat\": 2_0v0_6; 150705"
"Loading \".\\stars\\default\\stars_3_1v0_3.cat\": 3_1v0_3; 428466"
"Loading \"C:\\Users\\Chuck Boren\\AppData\\Roaming\\Stellarium\\stars\\default\\stars_4_1v0_1.cat\": 4_1v0_3; 1702042"
"Loading \"C:\\Users\\Chuck Boren\\AppData\\Roaming\\Stellarium\\stars\\default\\stars_5_2v0_1.cat\": 5_2v0_1; 7083058"
"Loading \"C:\\Users\\Chuck Boren\\AppData\\Roaming\\Stellarium\\stars\\default\\stars_6_2v0_1.cat\": 6_2v0_1; 24670782"
"Loading \"C:\\Users\\Chuck Boren\\AppData\\Roaming\\Stellarium\\stars\\default\\stars_7_2v0_1.cat\": 7_2v0_1; 50733321"
"Loading \"C:\\Users\\Chuck Boren\\AppData\\Roaming\\Stellarium\\stars\\default\\stars_8_2v0_1.cat\": 8_2v0_1; 92304337"
Finished loading star catalogue data, max_geodesic_level: 8
navigation/preset_sky_time is a double - treating as jday: "2457600.93611"
Reloading DSO data...
Loaded 10756 DSO records

It's even sadder whit you ask for help and get a condescending attitude from support.

Alexander Wolf (alexwolf) said : #18

Are you have Intel graphics card only? Please try run "Stellarium (ANGLE mode)" shortcut.

Chuck Boren III (chuckboren3) said : #19

Alexander Wolf
I've run the angle measurement (CTRL-A) shortcut and it runs fine without any trouble.

The following is the info for my graphics card:

Manufacturer Intel
Model HD Graphics 4000
Device ID 8086-0166
Revision A
Subvendor ASUStek Computer Inc (1043)
Current Performance Level Level 0
Driver version 10.18.10.3308

Alexander Wolf (alexwolf) said : #20

I meant not angle measurement, I meant ANGLE mode for Stellarium running (Start -> Programs -> Stellarium -> Stellarium (ANGLE mode))

Chuck Boren III (chuckboren3) said : #21

Alexander Wolf
I tried changing both config.ini file found in C:\\Users\\Chuck Boren\\AppData\\Roaming\\Stellarium\\config.ini and adding this to the file >QT_ANGLE_PLATFORM= d3d9 and the moon still disappears just as the solar eclipse begin. Then I repaired this ini file back to its original state and modified the default_config.ini file found in C:\Program Files\Stellarium\data with> QT_ANGLE_PLATFORM = d3d9 and still the moon disappears as the eclipse begins.
So what else can I do to make the moon visible during the eclipse?

Alexander Wolf (alexwolf) said : #22

Apparently we speak on the different English and you don't understand me. I said "Please try run "Stellarium (ANGLE mode)" shortcut" and suggested shortcut as "Start -> Programs -> Stellarium -> Stellarium (ANGLE mode)". Why you tried edit config.ini and default_config.ini files? What exactly you don't understand from my phrases?

Chuck Boren III (chuckboren3) said : #23

I tried your procedure Start -> Programs -> Stellarium -> Stellarium (ANGLE mode) but I only found Stellarium (ANGLE WARP mode). That did not solve my problem. Then I used this method found in http://www.stellarium.org/wiki/index.php/FAQ#ANGLE_mode where I followed: "ANGLE mode"
"We have first reports about missing buttons which seem to be related to errors in the ANGLE driver in Direct3D11 mode. If the logfile indicates something about GL renderer is "ANGLE (XXXXXXXXXXXXXX Direct3D11 vs_x_0 ps_y_0)" , you may be lucky if you set an environment variable QT_ANGLE_PLATFORM=d3d9 or even QT_ANGLE_PLATFORM=warp. Of course, the requirements vs_2_0/ps_3_0 or better remain the same for hardware acceleration".

So I tried to set the environment variable to: QT_ANGLE_PLATFORM=d3d9
That also did not solve the problem.

However, after trying some "hit and miss" approach, I found by turning the limiting magnitude switch button off, found in the "Sky and Viewing Options Window [F4], the moon stays visible during the solar eclipse.

Alexander Wolf (alexwolf) said : #24

Wait! You has an option "limit magnitude" is enabled and didn't said about it?

Alexander Wolf (alexwolf) said : #25