Help in loading dynamic plugin

Asked by Dhiraj Salian on 2016-07-25

hello,
I have created a dynamic plugin.When I load the plugin in the stellarium in which it is compiled, it loads properly.
But when the same lib[plugin-name].so is used to load in other stellarium it gives error of not a valid qt plugin.
How do I solve this???

Question information

Language:
English Edit question
Status:
Solved
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Solved by:
Alexander Wolf
Solved:
2016-07-27
Last query:
2016-07-27
Last reply:
2016-07-26
Alexander Wolf (alexwolf) said : #1

Can you share .so file for testing?

Alexander Wolf (alexwolf) said : #3

It works. Please check Qt version on non-development computer.

Dhiraj Salian (redcoder265) said : #4

In non-development computer it was installed from repository, Is there a way to make it compatible with most versions of stellarium??
And is there any need to set any environment variable to make it work???

Best Alexander Wolf (alexwolf) said : #5

Yes, you should use lowest possible version of Qt. For example plugin on Qt 5.3 will be work with Stellarium on Qt 5.3-5.7. Minimal version of Qt for Stellarium 0.14.3/0.15.0 is 5.3.0.

Dhiraj Salian (redcoder265) said : #6

Thanks Alexander Wolf, that solved my question.