App crash

Asked by VIRGIL B. BILARO on 2015-06-19

I recently installed the latest stellarium version (0.13.3-win64) on my laptop with a windows 7 64bit OS, and I have run it several times with no problem. I was previously running version 0.11.4-win32 on this same OS before I upgraded to the above mentioned version (0.13.3-win64) also with no problems encountered. Yesterday, I tried to download additional star catalogs via the tools tab when the power was suddenly interrupted (I wasn't using my laptop battery). When I tried to run the program again, it crashes. I uninstalled it, and tried to reinstall but the problem persists. I even cleaned the registry (using ccleaner) after I uninstalled and before reinstalling again but it doesn't work. I even checked the option to remove all data from previous stellarium installation/s when I reinstalled to make sure that all the previous program files are removed. I tried installing the older version that I had, and even the latest beta version but to no avail. All the versions install properly but they never run and show the same error. Windows shows the following details when I try to run stellarium:

Problem signature:
  Problem Event Name: APPCRASH
  Application Name: stellarium.exe
  Application Version: 0.0.0.0
  Application Timestamp: 553bab15
  Fault Module Name: MSVCR120.dll
  Fault Module Version: 12.0.21005.1
  Fault Module Timestamp: 524f83ff
  Exception Code: 40000015
  Exception Offset: 0000000000074a46
  OS Version: 6.1.7601.2.1.0.256.1
  Locale ID: 1033
  Additional Information 1: 090a
  Additional Information 2: 090ac2422ddeb407b98d4c0de5622755
  Additional Information 3: b495
  Additional Information 4: b49500f0de1bb4765ed030c230a52c57

Below are the details of the computer I'm using:

Windows 7 Ultimate SP1
Intel Pentium CPU B970 @ 230GHz
4.00 GB RAM
64-bit OS
Intel HD Graphics

Please help. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Solved by:
gzotti
Solved:
2015-06-19
Last query:
2015-06-19
Last reply:
2015-06-19
Best gzotti (georg-zotti) said : #1

Maybe some half-downloaded star catalog causes this?
Try if renaming your c:\Users\<you>\Appdata\Roaming\Stellarium folder helps. (A new one will be created.) If yes and you have data to keep (landscapes,...), move those over to the new folder, but don't move the broken "stars" folder.

If this does not help, see the logfile (Start menu->Stellarium->Last Run Log) for messages, and attach it if does not clearly say what happened.

When re-installing, make sure to automatically remove cache files and user data as well. (put them elsewhere if you want them.)

HTH, G.

I renamed the Stellarium folder and it runs already.
Thanks.