I can get Stellarium to work Runtime issue!

Asked by Justin McCollum on 2013-04-20

I am having issues with stellarium on my laptop computer. I recently installed Stellarium 0.12.0 while still having Stellarium 0.11.2 still on my computer. It was working great with all of my previous files and plugin from stellarium 0.11.2 transferred to my stellarium 12 expect the old satellite plugin file which stellarium asked to me remove and I clicked to have it removed. Then stellarium worked great, so I uninstalled stellarium 11.2 and 12.0v still worked, but now it is unstable. Everytime I tried getting to upload the screen with the daytime sky appears with the default landscape, but time short after the Microsoft visual C++ Runtime Library will appear with the following message:

This application has requested the Runtime to terminate it in an usual way.
Please contact the application's support team for more information.

I have installed and uninstalled from surgeforce more than once with both versions of 11.4 and 12.0 x32 and x64 on my windows 7 Home Premium edition serve pack 1 and all of my other programs on my computer are working just fine. However, I am still having issues with stellarium. Should I go back to stellarium 11.2 and if it still works on my computer, then install stellarium 11.4 or 12.0? No matter what I do it will not work properly.

Somebody please help with this otherwise I many stop using stellarium forever or until I get a new computer.

Question information

Language:
English Edit question
Status:
Solved
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Solved by:
Bogdan Marinov
Solved:
2013-04-21
Last query:
2013-04-21
Last reply:
2013-04-21
Best Bogdan Marinov (daggerstab) said : #1

Can you look at the log file produced after a crash and see if there are any suspicious messages? (There is a shortcut to the log file in Stellarium's folder in the Start menu.) Look for files not being found, etc.

Alternatively, have you tried running Stellarium in the "fallback"/"no OpenGL 2" mode? (Again, there's a shortcut in Stellarium's Start menu folder.)

In case this is caused by a bad satellite orbit, for example, you can also try deleting Stellarium's user data directory. On Windows 7, it the path is something like

C:\Users\YOURUSERNAME\AppData\Roaming\Stellarium

Also make sure that Stellarium can freely write to the user data directory, i.e. that there's no problem with file/folder access permissions.

Note that a bugfix version, Stellarium 0.12.1, has been just released, so you can try wiping the old installation (including the user data directory) and then installing the new version.

Justin McCollum (mccollumjjj) said : #2

I now have it working again!

Justin McCollum (mccollumjjj) said : #3

Thank You Bogdan!

I went deep into the registry to find the file you mentioned in deleted the Appdata/Roaming/stellarium along with every file and registry key connected to stellarium! One of the Reg-Ez file for the Appdata file mentioned above did not an assigned value and I had issues based on the log file about GL2 and GL3 with no problems with uploading any of the files, but it mentioned issues about succesfull upload in GL2, but not GL3!

Anyway I was able to download and install Stellarium 12.1 and I had no problems it worked right away; all of my additional data files with extra star catalogs and so forth will likely have to be installed, but that should be a problem with me it does not take that long.

I have no GL2 version for 12.1 but it does have a fallback mode and a'on the web' mode which I find interesting, so I will be rediscovering Stellarium once again.

Justin

Justin McCollum (mccollumjjj) said : #4

Thanks Bogdan Marinov, that solved my question.