Stellarium only runs as administrator

Asked by DRoberts on 2012-01-19

I've just installed Stellarium 0.11.1 on our PCs (running Windows 7 64 bit)
The program installs and runs OK as administrator, but won't run as a standard user.
The error is:
Microsoft Visual C++ Runtime Library
This application has requested the runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Can anyone suggest a solution to this?

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Stellarium Edit question
Assignee:
No assignee Edit question
Solved by:
Alexander Wolf
Solved:
2012-01-23
Last query:
2012-01-23
Last reply:
2012-01-20
Alexander Wolf (alexwolf) said : #1

Please show log.txt from Stellarium and check permissions on Stellarium's directories

DRoberts (duncan-roberts) said : #2

There isn't a log.txt, the program doesn't start.
Permissions are full access to everyone on the \program files (x86)\stellarium dir.

Best Alexander Wolf (alexwolf) said : #3

Please check permissions for user data directory of Stellarum - e.g. C:\Users\<LOGIN>\AppData\Roaming\Stellarium

DRoberts (duncan-roberts) said : #4

There isn't a Stellarium directory in the standard users profile, only in the admin profile (as thats the only account that can run it).
All users have full access to their own profiles.

Alexander Wolf (alexwolf) said : #5

Do you can create a Stellarium directory for unprivileged user into his profile like for admin for experiment?

Alexander Wolf (alexwolf) said : #6

I have question - your Win 7 used policy from Active Directory?

DRoberts (duncan-roberts) said : #7

Thanks Alexander Wolf, that solved my question.

DRoberts (duncan-roberts) said : #8

I followed your suggestion and created an empty Stellarium folder in the users \application data\ folder, and when I ran Stellarium it created the required files and sub folders correctly and worked.
The folder permissions are the same so I'm not sure why creation of the parent folder fails, but that seems to cure it. I'll manually create the empty folders for standard users.
Thanks.