Common problems with version 0.14/0.15

Created by gzotti on on 2015-10-24
Keywords:
Last updated by:
gzotti on on 2017-01-14

(1) GENERAL GRAPHICS ISSUES
===========================

Hardware requirements have not changed since V0.13 (see FAQ on Common Problems with V0.13 https://answers.launchpad.net/stellarium/+faq/2570 ).

>>Particular note for Windows 10 upgraders: <<
If you upgrade some older computer, you may have to also upgrade graphics drivers manually. Not all graphics card manufacturers provide drivers for Win10 explicitly for their old hardware, but some drivers for Win7/Win8 may work. If Stellarium V0.11 worked for you some years ago, it should work also here. If the hardware allows it, V0.14 will also work. Don't expect latest programs to run on outdated hardware without latest drivers though.
>> END of Windows 10 note.<<

Instead of special packages for older hardware, thanks to developments in Qt5.5 the Windows version now comes with links to force alternative graphics modes: ANGLE (OpenGL to DirectX translation) or MESA (software rendering). Modern hardware should be able to run the untagged "Stellarium" link, and you can happily delete the ANGLE and MESA startup links. Older hardware may require the special links and maybe even special handling which we learned ourselves from https://wiki.qt.io/Qt_5_on_Windows_ANGLE_and_OpenGL :

ANGLE MODE
----------------------
--angle-mode
We have first reports about missing buttons which seem to be related to errors in the ANGLE driver in its default Direct3D11 mode on older Intel GMA graphics. If the logfile indicates something about GL renderer is "ANGLE (XXXXXXXXXXXXXX Direct3D11 vs_x_0 ps_y_0)" , you may be lucky if you set an environment variable QT_ANGLE_PLATFORM=d3d9 or even QT_ANGLE_PLATFORM=warp. Of course, the requirements vs_2_0/ps_3_0 or better remain the same for hardware acceleration. Setting environment varlables is described e.g. here: http://superuser.com/questions/949560/how-do-i-set-system-environment-variables-in-windows-10.

V0.14.1 comes with two extra links: --angle-d3d9 and --angle-d3d11, which force the respective modes. So,

--angle-d3d9 should be tried if you just cannot see the menu buttons.

MESA MODE
---------------------
--mesa-mode
It appears that on some hardware even the MESA version which should emulate a proper GPU fails. It is very unclear at the moment what we could do here. Software rendering is also available via ANGLE, so maybe try the ANGLE version with environment variable QT_ANGLE_PLATFORM=warp (V0.14.1 directly provides option --angle-warp, but it also appears not to work on some systems where native OpenGL works...) and please report with your logfile if this helps. Alternatively, please copy the file opengl32.dll from an earlier version into the Stellarium 0.14 program folder and rename it to opengl32sw.dll. This worked in one case, but not in another.

OS X
----------
We have reports that upgrading to El Capitan solved graphic issues. One user's Mac still crashed when zooming in on ringed planets. As always, workarounds, hints, patches welcome.

TECHNICAL BACKGROUND
========================
Qt is collecting a blacklist of insufficient devices here:
https://code.qt.io/cgit/qt/qtbase.git/tree/src/plugins/platforms/windows/openglblacklists/default.json
If your device is listed, see the known limitations. If both OpenGL and ANGLE/Direct3D are disabled, you are out of luck.

(2) MOUSE CURSOR INVISIBLE
==========================

Still an issue in this version. Some users reported mouse cursor is invisible. This is true for the default OpenGL mode on Windows when you have Mouse Trails enabled or another reason to use a "software cursor", like f.lux screen color temperature modifier.

Make sure to switch off mouse trails to avoid this problem.

An anonymous user has reported a workaround: Use ANGLE mode when you need mouse trails or f.lux.

(3) HIGH DPI SCREENS
====================

If you are in the lucky one percent or so (https://www.netmarketshare.com/report.aspx?qprid=17) to have a High DPI screen (larger than 1920x1200, e.g. 2560x1440, 4k or similar), you may find the GUI fonts are too small. We received an anonymous hint with a solution (untested by us) that may work at least on Windows:

>here is the solution to the problem....
>
>http://www.danantonielli.com/adobe-app-scaling-on-high-dpi-displays-fix/
>
>I tried this on my Hi DPI machine and it works great with Stellarium 14!

More info: http://doc.qt.io/qt-5/highdpi.html

The solution is now built into 0.14.1.

(4) TROUBLE WITH DOWNLOADING STAR CATALOGS
============================================
We had reports that on some Windows systems the star catalog update does not work. See the logfile for these messages:

Error downloading star4:
Error creating SSL context ()

To solve, user Austin has tested this solution (https://sourceforge.net/p/stellarium/discussion/278769/thread/e0679ae8/):

1) Go here: https://indy.fulgan.com/SSL/
2) Download latest OpenSSL file.
(I downloaded "openssl-1.0.2j-x64_86-win64.zip".)
3) Open the zipped archive and find these two files:
libeay32.dll
ssleay32.dll
4) Extract these 2 files to the main folder of your Stellarium installation.
(For example: C:\Program Files\Stellarium\ )

Start Stellarium, and the star catalog updater should now work perfectly fine.
The libraries have been packed into our beta installers for Windows after 0.15.1.

(5) STELLARIUM CRASHES WHEN ZOOMING IN TO LESS THAN 5.8°
========================================================
https://sourceforge.net/p/stellarium/discussion/278769/thread/557aa8e5/#6536/4066

There was a change in the star catalogs, and I had such a "zoom to 5° crash" during development. Extra stars should be in C:/Users/YOU/AppData/Roaming/Stellarium/stars/default. Simply rename default and try again please. If this helps, delete the renamed folder and re-download the updated catalogs. (A new folder "default" will be created on launch.)