Framework not found Sparkle (XCode 3.1)

Asked by Jash Sayani

I am trying to Build an old project with XCode 3.1 that I downloaded with iPhone SDK Beta 6.

When I Build the project, I get the following error message during Linking process:

Command /Developer/usr/bin/gcc-4.0 failed with exit code 1
Framework not found Sparkle

NOTE: I have checked the project, the Sparkle framework folder is there in Framework section.

Question information

Language:
English Edit question
Status:
Answered
For:
Sparkle Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Andy Matuschak (andymatuschak) said :
#1

Sounds like something's weird with your project's frameworks search path. Try removing the framework from the project and adding it again. Failing that, please email me the project at <email address hidden>, and I'll see what I can do.

Revision history for this message
Jash Sayani (jashsoft) said :
#2

I removed the framework and compiled the source-code, it said Successful. Then when I run the application, it crashed with error code 1. So I again added the framework again and then it gave me the same error as before....

Revision history for this message
Andy Matuschak (andymatuschak) said :
#3

I'm pretty sure you're missing the copy files build phase; check the console to see the error that's coming up when it crashes.

Repeat that step in the Sparkle tutorial, and it should work. If it still crashes, please reply with the console log.

Revision history for this message
Jash Sayani (jashsoft) said :
#4

What do you mean by "Missing copy files build phase" ?
And how do I check with the Console ?

Some explanation would be great.

Revision history for this message
Andy Matuschak (andymatuschak) said :
#5

Go to http://foolsworkshop.com/applescript/2008/05/adding-a-check-updates-feature/ and search for "Copy Files"; repeat that step, making sure "Frameworks" is selected in the destination popup.

By the console, I mean Xcode's run console, which displays your application's STDOUT. Run -> Console.

Revision history for this message
Gustavo Moya Ortiz (gustavo-moyaortiz) said :
#6

On Xcode 3.1 you must add the Search Path for the Frameworks you are using to build the project.

1.- Add the Frameworks to the frameworks folder
2.- Create a Build Phase -> Copy Files, then select Destination = Frameworks
3.- Drag from the Sparkle Framework from the Frameworks Folder to the Build Phase you just created
4.- Scroll to the top of the project and hit Command + I (this will bring the Project Info Pane).
5.- Select the build tab
6.- On the Configuration Pop-up select "All Configurations", then on the Frameworks Search Field Write: Frameworks, this will filter until you see: SearchPaths -> Framework Serach Paths
7.- Double Click on: Framework Search Paths, then Add a New Framework Search Path, this will be where your frameworks are located, usually: "/Library/Frameworks", dont check the Recursive CheckBox.
8.- Hit Ok, Close the Info Pane and Build & Run the Project.

Can you help with this problem?

Provide an answer of your own, or ask Jash Sayani for more information if necessary.

To post a message you must log in.