GStreamer Error: gst-stream-error-quark: Internal data stream error.

Asked by Mike on 2018-05-31

First off, thank you to the maintainers of this project, this software package is very useful when it works for me.

I'm not sure how long now, possibly a year now, SoundConverter stopped working for me. That might have been with Ubuntu 17.04 or so, I'm really not sure. All I know is that it stopped working upon upgrade to a newer version of Ubuntu. I figured that the maintainers would notice that it doesn't work with the latest version of Ubuntu and simply issue an updated version to correct whatever problem it had, but in the year or so since the problem began, there has been no fix. This problem is not specific to my machine or my installation of Ubuntu. I've duplicated the issue on multiple computers with clean installs of Ubuntu. In the time since the problem began, I simply used another software package to accomplish the same task (Audacity), but that does not do multiple file conversions in a batch like SoundConverter, so it's much less efficient for this task.

The problem is this -- Upon completion of audio conversion to MP3, SoundConverter encounters and error and does not complete the conversion. The error is what I stated as the subject of this question -- "GStreamer Error: gst-stream-error-quark: Internal data stream error."

I have the following installed packages running on Ubuntu (Xubuntu actually) 18.04. I can provide additional system properties if requested.
Soundconverter version 3.0.0-2
gstreamer1.0-plugins-ugly version 1.14.0-1

Thank you!

Question information

Language:
English Edit question
Status:
Expired
For:
SoundConverter Edit question
Assignee:
No assignee Edit question
Last query:
2018-05-31
Last reply:
2018-06-15
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Ian Kay (yaknai) said : #2

I see the same problem on Ubuntu 18.04.1 with the same versions as mentioned above, and all updates applied as of Dec 3 2018

Mike (ms602) said : #3

It seems to have been resolved in later versions. I always stay on the latest release (rather than LTS) and am running 18.10. I just converted a file now, though I wasn't able to on 18.04 nor 18.04.1 either.

Richard Allen (allenr2) said : #4

Looks to me like the shorten codec is missing. I get the same error on Linux Mint 19.1 with all updates applied and I even tried the command line shntool and it also is unable to process any shn files because there is no "shorten" and that codec appears to be missing from where it used to be at http://www.etree.org/shnutils/shorten/dist/src/shorten-3.6.1.tar.gz and I can't find it anywhere else

sudo shntool conv -DDD -o flac *.shn
shntool [conv]: debug1: parsing [flac] encoder argument string originating from command line: [flac]
shntool [conv]: debug1: reading input filenames from command line
shntool [conv]: debug2: spawned input process with pid 847 and command line: "shorten" "-x" "Elvis195601.shn" "-"
shntool [conv]: debug2: waiting for [shorten] input process 847 to exit
shntool [conv]: debug2: process 847 exit status: [1/1] [0] [0]
shntool [conv]: debug2: spawned input process with pid 848 and command line: "shorten" "-x" "Elvis195601.shn" "-"
shntool [conv]: warning: failed to read data from input file using format: [shn]
shntool [conv]: + you may not have permission to read file: [Elvis195601.shn]
shntool [conv]: + arguments may be incorrect for decoder: [shorten]
shntool [conv]: + verify that the decoder is installed and in your PATH
shntool [conv]: + this file may be unsupported, truncated or corrupt

Richard Allen (allenr2) said : #5

I was wrong, installed shorten codec from source code at
https://download.tuxfamily.org/xcfaudio/PROG_ABS_FRUGALWARE/SHORTEN/

using instructions at
https://ubuntuforums.org/showthread.php?t=925167

and still get error gst-stream-error-quark: Internal data stream error. (1)

when converting any shn file. I did get the command line tool above to work, but soundconverter GUI still not able to handle shn files but works great for flac to wav