ALAC conversion not working

Asked by Mark Dodd on 2015-11-08

Hi,
I'm trying to convert my lossless .m4a files to either .wma or .mp3 but keep receiving the following error:

Required plugin could not be found
Python (v2.7) requires to install plugins to play media files of the following type: Apple Lossless Audio (ALAC) decoder

I'm running Ubuntu 14.04 and install Soundconverter 2.1.5 with the help from:
http://linuxg.net/how-to-install-soundconverter-2-1-4-on-ubuntu-14-04-linux-mint-17-elementary-os-0-3-deepin-2014-and-other-ubuntu-14-04-derivatives/

I tried the following:

sudo apt-get update
sudo apt-get install ubuntu-restricted-extras

without any success:

I also found on searching that this may also help for the ALAC codec....

sudo apt-get install gstreamer0.10-plugins-bad (but unfortunately it didn't).
sudo install alac*

As you can guess from my random tries I'm not very fluent with linux so if you can help with simple answers I'd be very helpful.

Many thanks in advance,
Mark

Question information

Language:
English Edit question
Status:
Solved
For:
SoundConverter Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Dodd
Solved:
2015-11-09
Last query:
2015-11-09
Last reply:
2015-11-09
GautierPortet (kassoulet) said : #1

I'm afraid there is no support for ALAC in gstreamer 0.10 applications like SoundConverter in Ubuntu 14.04.

You can try a gstreamer 1.0 version: https://launchpad.net/soundconverter/3.x/3.0.0-alpha1 if you feel adventurous.

or you can decode the files to wav using alac-decoder and then convert with SoundConverter.

Mark Dodd (mark-j-dodd) said : #2

OK thank you for the reply and informing what the problem is.
I'll just have to wait for the 3.0 version as to compile and run will be beyond my very limit capabilities.

One final point with your answer in mine why does it mention ALAC on the http://soundconverter.org/ website? This is what lead me to soundconverter and what confused me into thinking I could use it. It's still excellent at converting to other formats though and I'll still keep on using it. Keep up the good work!

Mark