Sub-folder structure not re-created

Asked by tarantoga on 2014-09-23

I'm using a folder structure like this:
music.FLAC/artist/album/bar.flac
if it's a single CD.
If the album has multiple CDs, I use
music.FLAC/artist/album/cd-number/bar.flac

I use SoundConverter to convert the flac files to mp3 with the same structure, but another base folder:
music.MP3/artist/album/bar.mp3
music.MP3/artist/album/cd-number/bar.mp3

Settings are:
Place results in music.MP3
Create subfolders artist/album
How to name files? same as input, changed suffix

In my old system (Ubuntu Lucid) I have SoundConverter 1.4.4 and it recreates my folder structure, even with the additional cd-number sub-folder.
My new system (Xubuntu Trusty) has SoundConverter 2.0.4 (same settings) and does not recreate the sub-folders, and I only get music.MP3/artist/album/bar.mp3 (not music.MP3/artist/album/cd-number/bar.mp3). All files are now in one folder, even though the source has sub-folders.

I have a bunch of scripts that rely on the fact that the folder structure is identical.

How can I enable the "old" behavior?

Question information

Language:
English Edit question
Status:
Solved
For:
SoundConverter Edit question
Assignee:
No assignee Edit question
Solved by:
GautierPortet
Solved:
2014-10-17
Last query:
2014-10-17
Last reply:
2014-10-06
Best GautierPortet (kassoulet) said : #1

This is tricky.
The easy solution is just to organize with the complete scheme: artist/album/cd/title, with a custom filename pattern.

Another way is by using the automatic folder reproduction, what you were using with 1.4.4.

When SoundConverter starts, it tries to reproduce your folder organization.
For this to work, you have to pass multiple files/folders.

It's really simple: first: disable "create subfolders".
then select your destination folder (music.MPĀ£ in your case), the same you are already using.

The catch is now: SoundConverter uses the common root of all files passed as a base folder.
so if you pass:
path/artist1/album1 and path/artist1/album2, the common path is path/artist1/
In your case, you must pass either multiple artists, or add another file to the root of you input path, just to trick
SoundConverter to recognize "music.FLAC/" as the common root folder.

so either:
path/artist1/album1 and path/artist2/album2, -> common path is path/, want you want
if you are converting just one album:
path/artist1/album1 and path/dummyfile.mp3, -> common path is path/, want you want

This way, your organization is be preserved.

I hope this is clear!

tarantoga (tarantoga-2) said : #2

Since I cannot easily change the naming scheme I tried the dummy file solution and it works very well.
Thank you very much!

tarantoga (tarantoga-2) said : #3

Thanks GautierPortet, that solved my question.