Batch convert to m4a

Asked by Erik van Nimwegen on 2012-12-14

Hi,

I am on ubuntu 12.04 and have installed the gstreamer plugins so that, through the GUI, I can convert flac files to AAC (.m4a). I have to, however, convert a large set of directories and rather than do it by hand I was planning to run a shell script that converts the files from all directories and moves them to appropriate target directories (which are of course all different). Therefore I wanted to use soundconverter From the command line.
But.. it first took me a bit to find out what 'mime-type' to use to get .m4a. From looking in the code I am guessing it is audio/x-m4a.
However, when I do a test I get this error/output:
soundconverter -b -m audio/x-m4a -s .m4a testfile.flac
...
Traceback (most recent call last):
  File "/usr/bin/soundconverter", line 2965, in <module>
    main(args)
  File "/usr/bin/soundconverter", line 2961, in main
    cli_convert_main(args)
  File "/usr/bin/soundconverter", line 2926, in cli_convert_main
    c.init()
  File "/usr/bin/soundconverter", line 1243, in init
    encoder = self.encoders[self.output_type]()
  File "/usr/bin/soundconverter", line 1364, in add_aac_encoder
    (self.aac_quality * 1000)
TypeError: unsupported operand type(s) for *: 'NoneType' and 'int'

Also, is there a way for me to control the bitrate and output directory from the command line?

Thanks so much for any help,

Erik

Question information

Language:
English Edit question
Status:
Answered
For:
SoundConverter Edit question
Assignee:
No assignee Edit question
Last query:
2012-12-14
Last reply:
2012-12-27
GautierPortet (kassoulet) said : #1

You should try to set the AAC Quality setting in the GUI.
And then restart the batch processing.

Can you help with this problem?

Provide an answer of your own, or ask Erik van Nimwegen for more information if necessary.

To post a message you must log in.