Conversion of SACD

Asked by Tim Arnold on 2011-10-07

Hi - trying to convert FLAC sourced from an SACD to mp3. Details of the media: Sample rate: 88200 Hz. Bits per sample: 24. Stereo.

Doesn't seem to work. I get the error "GStreamer encountered a general stream error." Other conversions from cd-sourced FLACs to mp3s work flawlessly for me. Is it not possible to convert this type of file to mp3 with SoundConverter?

Question information

Language:
English Edit question
Status:
Solved
For:
SoundConverter Edit question
Assignee:
No assignee Edit question
Solved by:
Tim Arnold
Solved:
2011-10-20
Last query:
2011-10-20
Last reply:
2011-10-20
GautierPortet (kassoulet) said : #1

Do you know where I can find an example SACD file?

GautierPortet (kassoulet) said : #2

Well, it works here. What version of SoundConverter are you using?

Tim Arnold (ww3ib-tim) said : #3

Version 1.4.4.

GautierPortet (kassoulet) said : #4

Tested with ubuntu 11.10 and soundconverter 1.4.4, and converting was OK.
This propably related to an older version of GStreamer.
I don't think I can do anything more for your problem.

Tim Arnold (ww3ib-tim) said : #5

This is a new 10.04 LTS install with newest gstreamer. Don't think this is the problem. Are there other required software packages that you have that I may be lacking?

GautierPortet (kassoulet) said : #6

I've all the gstreamer plugins installed.
You can try to upgrade to a more recent soundconverter.
Also, version 1.4.4 doesn't like folders with spaces.

Tim Arnold (ww3ib-tim) said : #7

I installed ubuntu restricted extras, all of the gstreamer plugins I could find, compiled and installed SoundConverter 1.5.4 from source - I still cannot convert this type of SACD FLAC to mp3. Playback of this type of file and conversion of other types of FLACs still works fine.

Tim Arnold (ww3ib-tim) said : #8

Aha! A small breakthrough...

It helped to change the resample rate to 44 kHz in the preferences menu - this seemed to work fine.

I also tried 48 kHz and this worked fine one file at a time, but froze up my machine each time I opened an entire folder. I tried 72 kHz - this resulted in GStreamer error when creating pipeline could not link audioconvertX to lameX. At 96 kHz i got the same error with different values for X.

My conclusion is this: when converting this type of FLAC you must select resample, and then the resampling rate must be kept under 72 kHz.

I will set this question to solved, but I am a little disappointed that SoundConverter can't keep the native sampling rate for this type of file.

Thanks for your help.

Kris (kristian-holsheimer) said : #9

I know that this discussion has been closed for a while now, but I'm having the same problem (on ubuntu 13.04) trying to convert 24bit/96kHz flac files to mp3 (or any other format). The suggestion of resampling to a lower frequency doesn't solve it, though. In my case, soundconverter doesn't freeze up my system, but rather just spits out empty files and it displays the dialog saying "GStreamer encountered a general stream error."

Any suggestions?

GautierPortet (kassoulet) said : #10

The maximum sampling rate for mp3 is 48KHz. You have to resample it.
Do you have a small sample file available ?

mikecaines (mikecaines-gmail) said : #11

This issues does still exist. I don't think the problem is on the output side, as I choose MP3 and resample to 44.1khz, but it still fails. The input file is 24bit and 96khz.

Chris Hermansen (c-hermansen) said : #12

Today I had similar problems in Ubuntu 13.10 - GStreamer general stream errors.

I was trying to convert FLAC files at various bit rates - some would convert, some would not.

Turns out pulling the latest source and compiling it fixed the problem.

I don't know if this will help with the SACD / DSD file, but it's worth a try.

DooMMasteR (winrootkit) said : #13

I encountered the problem on Ubuntu 14.04.
Sampling rate does not matter, but gsteamer fails decoding the 24bit FLAC files regardless of the sampling rate.