Cannot find root file system

Asked by Anne Gentle

I'm booting a Dell laptop to the Strawberry iso, and set the live image to use 50 MB of persistent storage.

Once I made the laptop use the USB as the first boot device and booted it, I get this error:

WARNING: Cannot find root file system!
Create symlink /dev/root and then exit this shell to continue the boot sequence.

With Google I found this Fedora thread:

I typed in
ln -s /dev/sda /dev/root

And restarted with ctrl+alt+del. The circle animation goes all the way around, but then I get the same message.

Has anyone else had this problem? Do I need a newer iso image?


Question information

English Edit question
Sugar on a Stick Edit question
No assignee Edit question
Solved by:
Anne Gentle
Last query:
Last reply:
Revision history for this message
Anne Gentle (annegentle) said :

The fix for me was to get strawberry-1 instead of strawberry ISO file. Getting the newer release fixed it, so this problem is solved.

Revision history for this message
Tim McNamara (tim-clicks) said :

Hi Anne,

Great to hear this is working for you now!

Are you able to send through links to the files that you downloaded? I guess it would be good to remove links that don't work to save the other people the trouble :)

Revision history for this message
Anne Gentle (annegentle) said :

The version I downloaded is available here:

I also downloaded the latest version of LiveUSB creator at

I still have difficulties getting it to work consistently, but have not found a consistent reason for problems.