Frame animation SVGs glitch in IE 11

Asked by Julia on 2015-05-12

This may be happening in older IE browsers as well, but I tried to implement fakeSMIL and it works beautifully-- except that at the beginning of the animation, there's a small glitch where all frames are shown at once, before the animation kicks in.
I was wondering if anyone else had that/if there was a known solution.
Thanks!

Question information

Language:
English Edit question
Status:
Open
For:
FakeSmile Edit question
Assignee:
Lthere Edit question
Last query:
2015-06-01
Last reply:
2015-05-28
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Lthere (helder-magalhaes) said : #2

Hi Julia,

Can you add further information on the "small glitch"? How is that "before the animation kicks in"? If "all frames are shown at once", does that mean you have made the animation to do that?

A sample SVG file would be great to help us better understanding the issue. Thanks.

Julia (jzhu-k) said : #3

So I have a repeating animation of stars spewing out of the center, for example. And it continues on a loop. At the beginning of the first loop, in IE only, it will show all frames for a fraction of a second before actually starting the animation. From there, all future loops do NOT show this all-frames image. It doesn't show up on any other browser, so clearly isn't something I coded in.

All frames showing at once is similar to what the svg animations look like without FakeSmile.

I am having trouble finding a good place to upload an SVG file. If you have any better suggestions, let me know.
http://www.filedropper.com/testanimation-copy

Can you help with this problem?

Provide an answer of your own, or ask Julia for more information if necessary.

To post a message you must log in.