Does Silva 2.1 work with Zope 2.11?

Asked by ashre on 2009-09-18

Has anyone got this combination working? My test server is running Zope 2.10.6 and Silva 2.1 works fine but when I put the site on the production server which is running Zope 2.11.4 then I can't display any posts with images - instead I get this error:

Time 2009/09/18 14:28:29.459901 GMT+1
Request URL http://www.ion.ucl.ac.uk/@@index.html
Exception Type AttributeError
Exception Value get_container

Traceback (innermost last):

* Module ZPublisher.Publish, line 119, in publish
...
*
* Module Products.FileSystemSite.FSPythonScript, line 164, in _exec
* Module None, line 3, in content
<FSPythonScript at /ion/service_widgets/element/doc_elements/image/content used for /ion/service_widgets/element/doc_elements/image/mode_view>
Line 3

Any help would be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Silva Edit question
Assignee:
No assignee Edit question
Solved by:
Kit Blake
Solved:
2009-09-18
Last query:
2009-09-18
Last reply:
2009-09-18
Best Kit Blake (kitblake) said : #1

Silva has problems with Zope 2.11.4 which we haven't yet located (we have time earmarked for next week for solving this issue).

Silva works fine with Zope 2.11.3 and before. Sorry for the confusion; this was announced on the silva-general list in august, but not everybody reads it.

If you're using a buildout you can adjust the Zope version.

ashre (ashre) said : #2

Thanks, switched back to 2.10 for now