Silva doesn't recognize PIL

Asked by mallow on 2007-06-06

I followed the Install.txt, and then installed PIL in my python installation, Silva 2.0 Zope 2.10 python 2.4

Zope and silva work fine but I can't seem to get Pil to intergrate itself, Do I need to edit runzope.bat??

Question information

Language:
English Edit question
Status:
Answered
For:
Silva Edit question
Assignee:
No assignee Edit question
Last query:
2007-06-06
Last reply:
2007-06-07
mallow (princemallow) said : #1

OK more information
I edited the runzope.bat just for the fun of it and told it to go into the python directory to get it's python.exe instead of inside zope and running the bat file worked out; however unlike in silva 1.6 I don't get a small thumbnail to see what the picture is in edit mode.... Further more, I'm running zope as a service which is linked to "C:\win32app\2.10.3\Python\PythonService.exe" instead of the runzope.bat. Is there a way for zope to process its information through python 2.4 ? Why does zope has its own version of python?

mallow (princemallow) said : #2

UPDATE, nevermind about the Thumbnail, seems like an update issue, thumbnail issue has been solved, but look into the other stuff.

Kit Blake (kitblake) said : #3

Zope has its own version because you may want to run different Zope versions (or even different Pythons). I'm not up to speed on windows config, but it sounds like you have the Zope Python using Pil now.

Can you help with this problem?

Provide an answer of your own, or ask mallow for more information if necessary.

To post a message you must log in.