Subnavigation - does not show

Asked by Christian Volz on 2013-02-05

Hi folks,
I am a beginner to Silva and I am struggling with the subnavigation.

In all documents I have found it says that the subnavigation is automatically filled with the titles of documents in the folder. However, this does not take place in my case. The subnavigation just shows the title of the index-document. Nothing is shown from my other Documents or Folders.

I know there is a option in the properties where you can hide the the document. However, this option is not activated in my case.

Does someone has an idea what I am doing wrong?

Best regards,
Chris

Question information

Language:
Spanish (Venezuela) Edit question
Status:
Answered
For:
Silva Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-05
Last reply:
2013-02-06
Kit Blake (kitblake) said : #1

Chris,
Which version of Silva are you using? There are huge differences between the 1, 2, and 3 ranges.

it's not clear what subnavigation you're talking about. Maybe you can post a reference to the documents you're reading. Is the nav in a document, like a Table of Contents, or in layout templates?

Regardless of which version you're using, you should be able to create a Table of Contents, either embedded in a document or by adding an Automatic Table of Contents item, and this will show the site hierarchy and link to folders (as opposed to index documents) and docs contained in folders. Navigation in a layout template should have the same behavior, but it depends on the code being used to generate the links.

Regards,
Kit

Can you help with this problem?

Provide an answer of your own, or ask Christian Volz for more information if necessary.

To post a message you must log in.