SNN Inline news viewer

Asked by mallow on 2007-09-28

I seem to be having a strange error, Everything seemed to be going well but with this new publication I get the following error...

(both on my dev server and on the actual one)

"c:\win32app\phptest\Products\SilvaNews\InlineViewer.py", line 113, in to_html return ustr(getattr(self, 'view')(**kwargs)) File "C:\win32app\2.10.3\Zope\lib\python\Shared\DC\Scripts\Bindings.py", line 313, in __call__ return self._bindAndExec(args, kw, None) File "C:\win32app\2.10.3\Zope\lib\python\Shared\DC\Scripts\Bindings.py", line 350, in _bindAndExec return self._exec(bound_data, args, kw) File "C:\win32app\2.10.3\Zope\lib\python\Products\PageTemplates\ZopePageTemplate.py", line 331, in _exec result = self.pt_render(extra_context=bound_names) File "C:\win32app\2.10.3\Zope\lib\python\Products\PageTemplates\ZopePageTemplate.py", line 427, in pt_render result = PageTemplate.pt_render(self, source, extra_context) File "C:\win32app\2.10.3\Zope\lib\python\Products\PageTemplates\PageTemplate.py", line 89, in pt_render return super(PageTemplate, self).pt_render(c, source=source) File "C:\win32app\2.10.3\Zope\lib\python\zope\pagetemplate\pagetemplate.py", line 117, in pt_render strictinsert=0, sourceAnnotations=sourceAnnotations)() File "C:\win32app\2.10.3\Zope\lib\python\zope\tal\talinterpreter.py", line 271, in __call__ self.interpret(self.program) File "C:\win32app\2.10.3\Zope\lib\python\zope\tal\talinterpreter.py", line 346, in interpret handlers[opcode](self, args) File "C:\win32app\2.10.3\Zope\lib\python\zope\tal\talinterpreter.py", line 586, in do_setLocal_tal self.engine.setLocal(name, self.engine.evaluateValue(expr)) File "C:\win32app\2.10.3\Zope\lib\python\zope\tales\tales.py", line 696, in evaluate return expression(self) File "C:\win32app\2.10.3\Zope\lib\python\Products\PageTemplates\ZRPythonExpr.py", line 49, in __call__ return eval(self._code, vars, {}) File "PythonExpr", line 1, in File "c:\win32app\phptest\Products\SilvaNews\InlineViewer.py", line 147, in get_items return adapter.getitems(number)

I've almost have it narrowed down to something, but I'm not sure what that something is yet... I'll keep you posted

Question information

Language:
English Edit question
Status:
Solved
For:
Silva Edit question
Assignee:
No assignee Edit question
Solved by:
mallow
Solved:
2007-09-28
Last query:
2007-09-28
Last reply:
mallow (princemallow) said : #1

I have a bunch of inline viewers in a page, and the funny part is if I isolate the problem inline viewer it works fine... I don't think the number of inline viewers is affecting anything since I have a page with twice as many viewers...

mallow (princemallow) said : #2

Things I've tried:
I've taken the filter that is linked to the viewer that is linked to the inline viewer and I removed all publications from it's source. The page with more than two inline viewers shows the error, the page with only two of the same viewer show 'no articles availible'

ah.. interesting tidbit, I've linked the problem viewer to another viewer and the error disappears, so there seems to be a problem with the viewer or filter in general?

I've relinked the viewer that the inline viewer refers to, to the filters that the other working viewer above is linked to and I still get the error which would indicate to me that the problem is somewhere in the viewer I will remake another viewer and see what happens

Very weird I had to make a new viewer in order for the error to go away, any thoughts on why that is... I know this error is probably hard to recreate without my data files, which is unfortunate, but maybe you've seen this before?

mallow (princemallow) said : #3

I don't know why but creating a new viewer did not fix the problem... It seems to me that for some reason, this particular viewer doesn't want to get called twice. It works when I call it once, but the second time it causes an error. (I call all my viewers twice so that I get one article with an introduction and then the second call generates a list of some other articles in that category) So since I didn't delete the old viewer, I am temporarily fixing this by having two viewers. which is odd but works for now.