Unable to save Sikuli scripts

Asked by frizzlefrazzle on 2010-01-31

I can't get Sikuli to save a script. Saving a file is usually not difficult. I don't know why saving in Sikuli is.

It seems like it should be as easy as saving in anything else. I clicked on "Save as" and saved as "test", "test.sikuli", "Firefox", "Firefox.sikuli" and none of them actually saved as anything. Please see the example video at YouTube.

http://www.youtube.com/watch?v=T0s89mXaFWc

In the example video I wrote a simple switchApp(app) script to open Firefox, demonstrated that the script works and then tried to save it.

What is the trick?

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
frizzlefrazzle
Solved:
2010-02-01
Last query:
2010-02-01
Last reply:

I downloaded 2010/01/28 Sikuli-IDE-win-20100128.zip (Portable version. No installation required.) and am now able to save scripts as easy I thought it would be.

I had originally installed 2010/01/28 Sikuli-IDE-win-20100128.exe (Self-extracting installer) believing the "portable" meant for portable devices. I still don't know the difference, other than the portable version saves scripts and the other version does not. I clearly have a lot to learn.

 I too cannot save any of my files, whenever I try, it too goes to the "Open" gui command. Please help! I need to be able to save files to use Sukuli properly.

ginger (ginger-jiang83) said : #3

 I also met this issue after install the latest build Sikuli-IDE-win32-0.10.2.zip (md5, sig)